Juliaup and Julia 1.8.0

Having been away from my computers for a while, I ran juliaup up a couple of days ago, and it upgraded my system to Julia v. 1.7.3. IJulia ran fine, using kernel 1.7.3.

Today, I did juliaup up again, and it installed Julia v. 1.8.0. But when I run jupyterlab(), no kernel is found (although 1.6.3 and 1.7.3 are listed).

Also, seems like I must re-install packages after I run “juliaup up”? I have had to re-install IJulia both days. Perhaps that is how it should work?

I think you need to run pkg> build IJulia in 1.8 to install the 1.8 kernel.


Thanks – that fixed the problem.

Question: when I install package IJulia and run Jupyter notebooks in a browser, the installer adds some Python code. Right?

If I run Jupyter notebooks via the VSCode plug-in, does that also add Python code, or did Microsoft build the plug-in without using Python?

[I’m curious because in the past, I had some problems with a previously installed Python version, and the one that was installed via `IJulia`…]

The native notebook support in the Julia VS Code extension has no dependency on Python or Jupyter installations at all, everything that is used for that scenario just ships in the extension itself and it should be entirely independent of anything else on your system.