Underscore not displayed in the Juno's REPL


#1

Hi,
The underscore character appears as a white space in my Juno’s REPL.
Do you have similar experience ?


#2

Works fine for me with v1.0.2.


#3

Thank you. I also run v1.0.2 and an up to date juno… (1.34.0 atom and 0.2.0 uber-juno).
On the following screen shot I wrote toto_4 both in the editor and in the REPL:


#4

I have an older atom: 1.33.1 for Atom and uber-juno 0.2.0
(But after checking them, somehow I messed up my Atom (juno) and don’t have time to resolve it now.)


#5

This is a known upstream issue with the terminal library used by Juno:


#6

Sorry. I have looked for underscore on discourse but not on the Juno’s issues.
FWIW the problem disappears when I check the FallBack Renderer Console option.


#7

How did you fix it exactly? I’ve been having that issue for a while and will like to figure it out.


#8

I clicked Julia button in the top menu
-> Settings
-> Console Options (you have to scroll down a bit)
-> validate the Fallback Renderer button
It solved the problem in my case.


#9

I changed to a different font.


#10

Which one worked? Deja Vu Sans Mono doesn’t display the underscore and cuts the lower part of j and g.


#11

The FallBack Renderer did not solve the problem ?


#12

The Fallback Renderer option should definitely be a workaround for this issue.

Source Code Pro works fine for me.


#13

Deja Vu Sans Mono has very low-hanging underscores, for some reason.


#14

I finally settled for monospace. The Fallback renderer option alone didn’t fix it. But thanks for bringing it up in Discourse, because it was something that I was meaning to fix.


#15

Thank for the feed back. I like the Hack font.