Change REPL font size


#1

I just installed the latest Juno edition on my home system. The REPL is portrayed with a disproportionately large font:

How can I reduce it? Thank you.


#2

Right click on top left corner. A menu will appear. Select properties and select the option. This is what I do to adjust font size in REPL.


#3

Hm, that’s weird – the console font size should always be equal to that in the editor. Can you give me some more details about your setup? What OS, any display scaling options active any other potentially useful info?

Also, one thing you could try is to go to Settings > Packages > julia-client and enable the Fallback Renderer option.


#4

The context menu that appears when I click the top left corner of the REPL does not have a Properties item.


#5

This is on Ubuntu 18.04 with default display settings; the julia-client package is version 0.7.10.

I can not find the Fallback Renderer option in the Settings page. Can you give me hint on where it is?

Thank you.


#6

You should have a Julia menu entry in the menu bar:


which has a Settings... entry at the bottom.
If you don’t see that press Ctrl-Shift-P (or Cmd-Shift-P on macs) to bring up the command panel and type in Julia Client: Settings.

Either way you’ll get to the Julia specific settings Juno has – scroll down until you get to the Console Options headline and you’ll find the Fallback Renderer option:


Julia does not run in Atom!
#7

Thank you, that is pretty detailed. However, toggling on this option has no effect on the REPL:

Cheers.


#8

Hm, very weird. One last thing you could try:

  1. Go to the Atom Settings view
  2. Click on Editor
  3. Explicitly set the Font Family (and maybe Font Size) to something.

#9

That did it. Could someone please mark the previous post as the solution?

Thank you.


#10

Since you started the topic, only you have that option (may not be enabled in this category, in which case you should ask for it).


#11

Cool, glad it’s working fine for you now :slight_smile:

I don’t think marking a post as a solution is enabled in this subforum, but maybe @vchuravy can do something about that if he thinks it’s a good idea?