Unable to install or update package

I receive the following error:
ERROR: expected package IJulia [7073ff75] to be registered

That’s a fair expectation on part of the package manager, as IJulia is indeed registered! What does ] registry st give?

Thank for your response

Concerning the registry it gives the following response

Registry Status

[bbcd6645] JuliaComputingRegistry (https://github.com/JuliaComputing/JuliaComputingRegistry)

If I try to add a package this is what happens. The “expected package” varies

add GitHub - Jutho/TupleTools.jl: Type stable methods for small tuples

Updating git-repo https://github.com/Jutho/TupleTools.jl

Resolving package versions…

ERROR: expected package Mocking [78c3b35d] to be registered

I have Julia installed on two win10 computers. The same messages appear on both.

On one of the computers I made the installation one month ago. These problems did not show up then. The packages that I installed at that stage still work.


Are you using JuliaPro? If so, is there a particular reason for why you are using JuliaPro? You don’t seem to have the General registry installed, and Pkg is therefore trying to install packages from the JuliaComputingRegistry (which I think normally comes with JuliaPro).

I would strongly advise you use the latest stable release (1.6.1) of Julia rather than JuliaPro. If you have an actual need for JuliaPro, you could try adding the General registry to your current installation to see if that helps (I don’t know whether it will as I - like most others - have never used JuliaPro):

] registry add General

Thank you for your suggestions, but I am afraid that they did not work. The first version I tried was 1.6.1 but it is even more problematic on my systems. I could not download packages at all.


That’s odd - what errors do you see when you start a fresh REPL session on 1.6.1 and do add IJulia? What OS are you on? Are you behind some sort of firewall?

I hope that I have found the solution to the problem. Originally I changed the default installation folder in my attempts. For some reason this did not give an acceptable result, which it should have done. However, when the default folder was chosen, the installation of JuliaPro seems to work. I am quite surprised that this serious issue has not been observed by other researches. I have still not been able to make Julia 1.6 work.


I would suggest not using JuliaPro - to my knowledge it will not receive updates after the current version, and if you’ll search this forum you’ll find plenty of users reporting problems that no one could really help with as hardly anyone on here uses JuliaPro.

Are you saying that if you do a clean installation of Julia 1.6.1 with all default settings (just to narrow down the problem - I agree with you that it should be possible to change the installation folder), start a REPL session and do ] add IJulia this errors? If so, could you provide the full stacktrace?

I am sure that you are right. In the end Julia 1.6.1 is most likely better. I have found three major issues with the installation of Julia

  1. You cannot select your installation folder freely as I mentioned in a previous message

  2. After uninstallation of Julia a big amount of data remained. In my case more than 8GB with more than 100000 files. I had to remove it manually which is a dangerous process since you cannot have full control of it.

  3. The installations of Julia 1.6.1 and JuliaPro overlap and use the same folders to same extent that has uncontrolled consequences

I hope that other people can learn from these facts and avoid some of the installation problems. I am still surprised that other people have not identified and reported them.

To try installing Julia 1.6.1 I would have to uninstall a working version of JuliaPro. In addition a new installation would require a lot of data that is a problem with a modest internet connection at my Sommer house. I will try it when I am back home.


That’s fair enough - although 8GB also sounds pretty large for a Julia installation (unless you also had a lot of Python dependencies and becaue of that a large conda folder - but that seems unlikely given you said you were unable to install anything?)

In any case enjoy your summer house and when back I’d encourage you to have another go with Julia 1.7 (which will be released by then, and make some package operations much faster especially on Windows), people on here will surely be happy to troubleshoot any issues you might run into.

I am not surprised about the 8GB. The single installation I have now is more than 5GB and with two installations you would get much more.

The beta version for 1.7 is obviously out now. Yes, it is good idea to wait with the installation until the stable version of 1.7 appears.

Thanks again.