"ERROR: expected package... to be registered" in JuliaPro

I just downloaded JuliaPro 1.5.3 and am trying to follow this tutorial exactly: Julia Tutorial on YT. I went into Atom and tried to update the packages as was shown in the tutorial by issuing the following command:

(@JuliaPro_v1.5.3-1) pkg> up

But this gave me the following error:

ERROR: expected package `Juno [e5e0dc1b]` to be registered

I don’t understand what this means…How do I get Juno “registered” so that I can resolve this and continue on with the tutorial?

1 Like

I would try ]registry up and if that fails remove the registry entirely (it will get reinstalled the next time it is needed).


Thanks! I removed the registry and after it reinstalled it worked!

I’d like to add some information to @hendri54’s answer and hopefully help other beginners like me.

  1. Registries are folders under ~/.julia/registries/. In my case, there are two registries: “General” and “JuliaComputingRegistry”. To “remove the registry” means to delete defected folders under ~/.julia/registries/. For example in this case, delete ~/.julia/registries/General which Juno is registered to.
  2. After deleting, you can manually add General back using
(@JuliaPro_v1.5.4-1) pkg> registry add https://github.com/JuliaRegistries/General

Looking back, I probably had messed General up by interupting the update process. General should have subfolders named from A to Z but in my case there were only A to G. Juno should be in the subfolder J, hence the error message. Moreover, ~/julia/registries/General/Registry.toml was missing, so Pkg didn’t even know this registry exists, let alone to reinstall it automatically.


A post was split to a new topic: Update registry via the Pkg API?