Problems installing registries and IJulia with Julia v1.5.2 in Windows 10 64 bit

Installation issue - Could anyone help?
this is the command i use…but nothing is happening…keep says Installation known registeries… as mentioned below. I get no errors as well… what to do?

julia> using Pkg

julia> Pkg.add(“IJulia”)
Installing known registries into C:\Users\test\.julia

Is the folder C:\Users\test\ writable by the current user?
Do you have any network restrictions while you try to install the IJulia package?

This can take 3-4 minutes.
Take a look at "[...]\.julia\registries\General".
It must install the package registers from A to Z.

Yes, it is writable and i have downloaded multiple python packages earlier in the same folder.

No network restrictions too

I waited for very long time indeed

Seems odd.
Could you try to remove (or rename) the folder C:\Users\test\.julia and than start Julia and do the following commands:


(@v1.5) pkg> instantiate

(@v1.5) pkg> add IJulia

the ] means to enter ] at the REPL to enter Pkg REPL mode.

thank you for your reply. I tried removing the folder and tried with your command

(@v1.5) pkg> instantiate
Installing known registries into C:\Users\test\.julia

Still the same issue. Fundamentally, something going wrong. Can u help, possibly, taking my system remote?

Same issue means, that after instantiate it takes forever and never ends? Or is it with add IJulia?

thats right …
after instantiate it takes forever and never ends

I have changed the header of this thread.
We can do a teamviewer session but not too long. PM me with your teamviewer credentials.

Also, it is the same… never ending for this command as well

(@v1.5) pkg> add IJulia
Installing known registries into C:\Users\test\.julia

1 Like

552 069 763

It turned out, that with Julia 1.6 (nightly) there wasn’t any issue.
With Julia 1.5.2, after removing .julia, instantiate doesn’t start doing anything except for creating .julia and inside folder logs and there file repl_history.jl, but maybe this was created with the Julia start itself and not with instantiate.

Nothing else ever happens for a very, very long time.

Interrupting it with Ctrl-C prints an error that it can’t download some URL I don’t remember now.

Putting some print lines into and Base.download_powershell showed, that it never reaches the download functions (Windows curl.exe has been renamed before). So the error message is something else, initiate is waiting for something, does nothing, is not reaching download functions. I was not able to find out, what it is doing.

We have tried several things: no network issue and no permission problems.

Setting JULIA_DEPOT_PATH doens’t change anything except for the folder of course.

A very weird issue!

1 Like

Just have some patience. It takes a really long time. It looks like it has stopped, but then after some minutes it installs everything.

How long did it take you to install? I am having exactly the same issue and it has been going on for a while by now and I did observe that there are folders created under ~.julia\registries from A to Z.

Update: It finished after 20 min.

This may or may not be relevant. If working from the REPL, does attempting to install packages activate the powershell? I have had this problem for some time, and have given up trying to install any packages.