Ubuntu Julia 1.6.4, juypter notebook not connecting?

I’ve just updated to the latest version of julia, 1.6.4 or ubuntu 20.04, however this has been an ongoing problem with previous julia versions. I can not get the julia kernel to show up in jupyter notebooks. Jupyter is installed by the jupyter snap, and within Julia I’ve added and built IJulia but still no luck. When I attempt to execute a notebook from within Julia I get the following error. Any suggestions? Thx. J

julia> using IJulia; notebook()
[ Info: running `/usr/bin/snap notebook`
Process(setenv(`/usr/bin/snap notebook`; dir="/home/name"), ProcessExited(64))

Try to rebuild IJulia:

using Pkg

Thanks fredrikekre, as I said above, already did that, several times and still no luck. Thx. J

Found the problem, apologies. I was using jupyter which was running from an old “snap”, didn’t realise it is from 2019 so well out of date today (end 2021). I removed the snap, reinstalled jupyter using apt, started julia, added IJulia, build IJulia then executed

using IJulia; notebook ()

and it started a new jupyter notebook, and the new Julia 1.6.4 kernel was available!