Need Help with IJulia on Ubuntu 18.04.5 LTS

I am having a tiny issue with the Ijulia in jupyter notebook in my ubuntu setup

(@v1.5) pkg> add IJulia
  Resolving package versions...
  Installed IJulia ─ v1.22.0
Updating `~/.julia/environments/v1.5/Project.toml`
  [7073ff75] + IJulia v1.22.0
Updating `~/.julia/environments/v1.5/Manifest.toml`
  [8f4d0f93] + Conda v1.4.1
  [7073ff75] + IJulia v1.22.0
  [682c06a0] + JSON v0.21.1
  [739be429] + MbedTLS v1.0.3
  [c8ffd9c3] + MbedTLS_jll v2.16.8+0
  [69de0a69] + Parsers v1.0.11
  [b85f4697] + SoftGlobalScope v1.1.0
  [81def892] + VersionParsing v1.2.0
  [c2297ded] + ZMQ v1.2.1
  [8f1865be] + ZeroMQ_jll v4.3.2+5
  [7b1f6079] + FileWatching
   Building IJulia → `~/.julia/packages/IJulia/a1SNk/deps/build.log`

So It seemed to have been installed just fine.But
When I tried opening it in bash

julia> using IJulia
[ Info: Precompiling IJulia [7073ff75-c697-5162-941a-fcdaad2a7d2a]

julia> notebook()
[ Info: running `/usr/bin/snap notebook`
Process(setenv(`/usr/bin/snap notebook`; dir="/home/ashwani"), ProcessExited(1))

And
When Opened Jupyter notebook by normal direct method in other terminal


Pls Guide,any chance this could be due to web browser(this one is firefox)(nope same error persists in google chrome even/0??

I am on 20.04 now, but I never had problems in Ubuntu 18.04… I usually install jupyter in pip and then IJulia using the julia package manager… try ] build IJulia again… for sure it is not a browser problem :wink:

Not my area of expertise, but why are snaps coming into the picture here?
At a command prompt try snap list

Also how was Julia installed on this system?

Set enviroment variables

Or update jupyter notebook, pip, anaconda, or something related, idk for Ubuntu, same as windows?

I think I have the answer. I used an Ubuntu 18.04 VM and install Julia 15.2 under /usr/local/julia
When I install IJulia using the Julia REPL package manager I can do
using Ijulia
notebook()

BUT I now run sudo snap install jupyter
I now get
julia> notebook()
[ Info: running /usr/bin/snap notebook
Process(setenv(/usr/bin/snap notebook; dir="/home/vagrant"), ProcessExited(1))

My advice: you have the jupyter snap installed.
run sudo snap remove jupyter

I did this remove of the jupyter snap and now notebook() works fine

By the way, Pluto notebooks are lovely!

1 Like

Yes of course Pluto are lovely, but doesn’t lovely for open .jl file.