Troubles with Julia and VSCode

Basically I’m having trouble using Julia in VSCode with the whole “Could not start the Julia language server. Make sure the julia.executablePath setting points to the Julia binary.” and “Cannot read properties of undefined (reading ‘file’)” thing you all probably know already.
I tried following other topics but no luck.
I was using Julia 1.6.7 and had no problem at all with VSCode, the path was recognized automatically, I had to change to 1.8.0 and I can’t seem to solve this. I am very naive programming/computer-wise so I apologize in advance for any silly things I may say.
I am running Windows 7 64 bits, the VSCode version is the latest avaible for Windows 7 (version 1.70.3, which was working fine with Julia 1.6.7).

I don’t know what you’re referring to. I suggest giving complete information if you want help.

Those in quotes are the messages that pop up on vscode when trying to run julia…

Welcome to the community. Please install Julia with juliaup and it will setup things correctly. Also consider installing Julia v1.9.


@juliohm Can I even install Julia with julia up on Windows 7? I’m not being able to find a way…

Yes, it is in the Microsoft Store. See the link on GitHub (GitHub - JuliaLang/juliaup: Julia installer and version multiplexer), this gives you a command you can run in powershell:

winget install julia -s msstore

If this fails, search for it directly in the store. It is a good idea to uninstall your old versions of Julia as well and clear any custom settings you have in VS code.

Once installed run in powershell or cmd

juliaup add release
juliaup default release

For the latest version of Julia. This setup usually avoids the majority of issues and makes it easy to upgrade/downgrade Julia in the future.

I use julia with windows 7. I don’t know if this is related to your problems but you need to install the Microsoft Management Framework. Without it you run into all sorts of problems even though everything appears to be alright.

1 Like

No, at the moment Juliaup on Windows requires either the Windows Store or App Installer for installation, and neither is available on Windows 7.

I think if there is any way for you to update to a newer Windows version, I would try that. Windows 7 has been end-of-life for three years now, it is not even getting basic security updates anymore. Both Julia and VS Code have Windows 10 as a min version. I’m not even sure you can get recent VS Code versions to run on Windows 7?


Try this:

1 Like

Funny that it said I couldn’t install it on my PC… anyway, thanks for the help… I’ll use Pluto for the while.

I tried it and nothing happens after double clicking the file… thanks for the help anyway… I’ll stick to Pluto for now.

Nothing happened? Meaning you did not get a terminal popping up and saying something like “Downloading Git”?

The terminal popped up but immediately closed afterwards… no message. Note that I use windows 7 and according to the github page it was only tested for windows 10.

That is true. Sorry about that. I do not have Win 7 anymore, I’m afraid…

1 Like