VSCode Compatibility Issues

The problem is I can’t get Julia to run on VSCode. I’ve looked through posts from here, StackExchange, and Reddit, among other platforms to try and fix this issue. Not only does VScode not start Julia’s language server, but it also cannot locate the executable. I run a Linux, and the things I have tried are as follows:

  1. Set my Julia executable to PATH element (verified it as such through echo $PATH and typing the executable’s location in my terminal to successfully start Julia to verify it was a proper executable)

  2. Typed “julia.executablePath”: “/home/usr/julia-1.9.0/bin/julia” (the path to the executable file) in both the user and workspace tabs of settings in VSCode. The upper bar does say id:julia.executablePath so it should identify the path through that exact command. I have also tried adding .exe at the end of julia.

  3. used the add LanguageServer command in pkg mode on a Julia REPL (terminal in and out of VScode). VScode however did not recognize what was installed, I was still told that it couldn’t start the language server even after uninstalling and reinstalling VScode and the Julia extension.

If anyone could help me get VSCode to run Julia I’d be eternally grateful, I just want to start doing things with this language. The only idea I have left is to uninstall and reinstall Julia itself.

I would recommend installing via juliaup as this will sort out all of the paths for you, in a way that’s always worked for me with VS Code.

I would also remove any manual setting of executeable paths that you have done yourself before installing, along with any custom settings in VS code. Also remove existing julia installations from your path.

To install go to GitHub - JuliaLang/juliaup: Julia installer and version multiplexer and copy the command for linux. Once installed, run the following in the terminal:

juliaup add release
juliaup default release

When you type julia you should see it’s v1.9

Let’s see if that fixes your issue.

1 Like

That worked. Thanks!

1 Like