Trouble installing/setting up Julia 1.5.3

I am a new user and am having trouble setting up Julia 1.5.3., despite following the instructions here: http://docs.junolab.org/stable/man/installation/. (I am using Windows 10 and I downloaded 64-bit (installer). I made it as far as step 3 of the installation guide. When I then hit Enter in the REPL, I get the following error message:

“Julia could not be started. ‘“C:\Users\Michael\Julia 1.5.3”’ is not recognized as an internal or external command, operable program or batch file. We tried to launch Julia from: C:\Users\Michael\Julia 1.5.3 This path can be changed in the settings.”

I also tried “C:\Users\Michael\AppData\Local\Julia-1.5.3\bin\julia.exe.” Apparently this is not the right file path either…I’ve attached a screenshot from my file explorer showing where I installed Julia.

Apologies if this is a dumb question. I don’t have a very good understanding of file paths, and how they work.

Hello Michael. I use Windows 10 also. Please take this advice which I give here frequently.
Use the Chocolately package manager to install Julia on Windows
Please, please install Chocolatey then post here. i am happy to help

I also have to say this - I love Atom and worked with Juno. I really, really like Atom.
Sad to say this is now not being developed. The advice is to use VSCode.

Thanks for the suggestions, johnh.I just downloaded VSCode (I am going to hold off on Chocolatey for the moment.) I’m reading the Julia for VSCode instructions here: https://github.com/julia-vscode/julia-vscode#installing-juliavs-codevs-code-julia-extension. When I search for Julia under extensions, I see Julia 1.0.10 (Julia Language Support, it says underneath). Is this what I should be downloading? I thought that 1.5.3 was the latest version.

Can you check C:\Users\Michael\AppData\Local\Julia-1.5.3\bin\julia.exe is that really where Julia is installed? On my Windows 10 machine it’s under C:\Users\me\AppData\Local\Programs\Julia 1.5.3\bin\julia.exe.

Michael, if you are in VSCode can you just start the Julia REPL then run:

versioninfo()

1 Like

Hello, here is another screenshot that I think shows the location:

So it seems to me that C:\Users\Michael\AppData\Local\Programs\Julia 1.5.3 is the location. (Is this correct?) But sadly this still gives the same error…

Thanks for the help! It says version 1.5.3, so looks like it set up correctly!

I would check the Julia 1.5.3\bin directory verify that there is a file “julia.exe”. If you are NOT showing file extensions then it will just be “julia” by have a Type of “Application”. Then I would click the “Location” bar, the whole path should then be highlighted, copy it with Ctrl-C then paste that into the Julia Client config and add the \julia.exe. That should ensure that the path is correct and you didn’t typo anything.

Thanks for the detailed instructions. I did exactly that, but now when I go to the REPL and hit enter, it just says “Julia has exited. Press Enter to start a new session.” :frowning:

I do not have the smarts to find the julia.executablePath variable in my VSCode settings… sorry
My REPL reports version 1.5.3

Please try installing Julia using Chocolatey?

Hi Johnh, I have Julia up and running with VSCode, so I’m all set! (pixel27 was helping me out with Atom, but I couldn’t quite figure it out.) Oh well, I only need one editor!

Yaaayyy!

1 Like