The update from 0.5 to 0.6 does not seem to happen


#1

I am using Atom and I have updated Julia, or so I thought, from version 0.5 to version 0.6, but when I open the Julia terminal, the version shown is 0.5.2. Also, Atom fetches everything from a subdirectory labeled 0.5, not 0.6. Subsequently to updating Julia, I have updated Atom to the latest version, which is 1.18.


#2

I believe you can update manually. Download Julia 0.6, and in the Julia-client package set the name of the executable to that of 0.6 (when Julia is about to install it shows the path to the executable in the dialogue: copy it to the “executable” box in Atom.


#3

You seem to be using Windows. I am using Linux. I downloaded the compressed tarball, uncompressed it to the /usr/local/src directory, opened the resulting subdirectory in a terminal and got stuck trying to run ./configure on it. Besides, there is the concomitant complication of having to dispose of the previous versions properly.


#4

If you just uncompress the tarball then the binary should be already there (or at least that is how things work on Ubuntu). You should have a folder called julia in /usr/local/src, and the binary should be in /usr/local/src/julia/bin. So, if you go to the settings page that Petr showed and set your Julia path to /usr/local/src/julia/bin/julia, then you should be good to go. You can also make sure that the right version of Julia is accessible from the terminal by adding

export PATH="path-to-julia/bin/:$PATH"

to your .bashrc. In your case I think that path-to-julia is just usr/local/src/julia. As for the ./configure thing, it sounds like you might be trying to build from source, which is a whole different kettle of fish. If you want to build from source, then run make in the julia directory. The first time that you run make will take approximately a billion years (it has to build all of the dependencies), but the next time will be much faster. If you just want to use Julia, then I would recommend using the binary that is already built for your system. :smiley:

As for deleting the old Julia installations, sometimes it is useful to have the current version and an old version (especially right now when some packages are not fully v0.6ified). Personally, I have things like

alias julia0.5='path-to-julia0.5/bin/julia'

in my .bashrc so that I can access the old versions of Julia easily (also, Jupyter keeps track of all of your old kernels, which is really handy sometimes :wink:). However, if you really want to get rid of the old Julia installations, then just remember that Julia does not install outside of its own directory (except for .julia which is where all of your packages are). Therefore, uninstalling Julia is really easy.


#5

Thank you for all those details. I am getting closer, but it still doesn’t work. ->

We tried to launch Julia from:
usr/bin/local/src/julia-903644385b/bin/julia
This path can be changed in the settings.
Details:
/bin/sh: 1: usr/bin/local/src/julia-903644385b/bin/julia: not found

Formerly, only “julia” was written where “usr/bin/local/src/julia-903644385b/bin/julia” is now written. The julia executable was then in the same directory as the atom executable.


#6

Hmm, sounds like gremlins…

What happens if you type usr/bin/local/src/julia-903644385b/bin/julia into the terminal?


#7

Also, seeing the output of ls usr/bin/local/src/julia-903644385b/bin will tell you if the executable exists in the place that you think that it does.


#8

No file or directory of this type.


#9

What about the ls?


#10


#11

Woops, earlier when I said usr/bin/local/src/julia-903644385b/bin/julia I meant to say type /usr/bin/local/src/julia-903644385b/bin/julia (I forgot to put a slash at the start). Sorry about that, try again with the slash at the start.


#12

Still the same answer from the system.


#13

Ok, I have one last idea…

Try running the executable from the file manager that you have shown in the screen shot. You might be able to run it by clicking on it, but if not then you should be able to drag it into the terminal and the terminal should try to run the executable (after you press enter). If that doesn’t work then try cd usr/bin/local/src/julia-903644385b/bin/ followed by ./julia.


#14

Your last suggestion worked. I can now use the Julia terminal for version 0.6, but I can only use version 0.5 from Juno.


#15

Woops forgot the slash again lol, the commands that you want are:

cd
cd /usr/bin/local/src/julia-903644385b/bin/
./julia

#16

Oh cool, just saw your message, glad that you were able to work with my broken bash commands. At least we know that you have a working executable, now you just need to do the settings thing for Juno. You need to be careful to get the right directory and make sure that you put a slash at the beginning of the file path (unlike my earlier suggestions).


#17


#18

The screen shot of your file manager shows the path /usr/local/src/... but it looks like you are telling Juno to look in /usr/bin/local/src/...


#19

Sorry for the mishap. Here is what worked ->

I now have two directories that I would like to erase ->
/home/jean-victor/.julia/v0.3
/home/jean-victor/.julia/v0.4
I wonder if I can do this without breaking something.


#20

Hooray!! Deleting those directories should be fine, especially since neither of those versions of Julia are supported. I still have my v0.3 folder just for nostalgia purposes. If you are really worried about space, then go ahead and delete, but I don’t think that they should take up much room (unless you cloned everything in METADATA!).