Slider does not show after upgrade Jupyter

(I posted the query on the Jupyter forum, and was suggested that the issue might lie with Interact.jl . Therefore, I’m bringing the question here for further insights.)

I’ve been using Julia in Jupyter Notebook (NB) to make interactive plots with Interact.jl. It worked well until I upgraded Jupyter, and then the slider disappeared without any error messages.

Before the upgrade:

  • NB version 6 (6.4.12) worked fine.
  • Lab version 3 (3.4.4) had issues with the slider not updating graphs, but I didn’t mind since NB was okay.

After the upgrade:

  • NB version 7 (7.1.2) and Lab version 4 (4.1.5) both failed to show the slider, with no errors.
  • Downgrading to NB 6.4.12 fixed the issue for NB.
  • The current version of nbclassic also works.

However, downgrading isn’t a long-term fix and the nbclassic is a transitional product. So I’m looking for solutions for both NB (preferably) or Lab.

Someone from the Jupyter forum suggested that the issue may lie with the Interact.jl.

The problem’s MWE:

using Interact, Plots

@manipulate for n in 1:5:100

I’m on Windows 10 and 11, using ipywidgets 8.1.2 and Julia 1.10.2. I installed the widgets with:

  • conda install -n base -c conda-forge widgetsnbextension
  • conda install -n base -c conda-forge ipywidgets
  • jupyter nbextension install --py widgetsnbextension
  • jupyter nbextension enable --py widgetsnbextension

I’d appreciate any alternative solutions or fixes.

1 Like