Interact isn't generating anything in Juno for me anymore

I have been using the Interact.jl package within Juno for a little while now. Until recently it worked exactly as expected and created interactive elements in the plots window.

However, while playing around recently with an interactive plot I seem to have broken something by moving a slider to a value that crashed the program. Now whenever I run anything within the interact library I get no output at all (a new page opens in the plots pane and it’s completely blank). Everything else including the Plots library still works entirely as expected. This issue seems very bizarre to me, and I am wondering if anyone has heard of something similar or has ideas around how to fix it.

To make sure the problem isn’t because of something wrong with my code, I wrote this simple function which isolates the issue:

using Interact

function test()
    @manipulate for i ∈ 1:10
         @show(i)
    end
end

test()

When I run this in Jupyter notebook with IJulia, I get a slider just as expected. However when I run it in Juno I get a completely blank plots pane.

Here’s what I’ve already tried:

  • restart Atom
  • restart computer
  • completely uninstall all Juno packages from Atom then reinstall
  • completely uninstall Julia and delete everything in ~/.julia then reinstall and re-add all packages

For reference, I am running macOS Catalina and Julia 1.4. If anyone has any thoughts on this, they would be much appreciated!

update atom itself above than 1.48 will solve this

1 Like

This worked—thank you so much!