Selecting text with keyboard (shift+left/right) in Juno under Win10

I try to select text using “shift+left” or “shift+right” in the REPL. But it does not work (a colleague testet it on linux with juno, there it works).
I tried google, but I likely look for the wrong keywords. I also don’t really know what kind of “shell” julia is using. Marking with shift+left etc. also does not work if I run julia-repl directly.

This is something I usually use quite often. Any way to get it to run?

You can check in the Juno settings in Atom, but if you haven’t changed any defaults (which I assume you haven’t given you’re asking!) it should be using PowerShell.

I can confirm that when running Julia in PowerShell I can’t shift+left/right select text either, althouth surprisingly it works in PowerShell outside of Julia. You could try with the new Windows Terminal - can’t check right now whether that will help unfortunately as I’m on a work laptop.

Thanks for confirming. I can also mark text both in cmd.exe and in powershell.exe.

Changing the config (and restarting) did not change behaviour at all for me. Is this the shell for the repl, or is it the shell that is used when going to shell-mode in the repl (";")?

Not sure I understand - what I was saying is that for me, using Julia through cmd or PowerShell in Windows does not allow text selection.

Afaik the REPL in Juno is the same as starting PowerShell and then running Julia in that PowerShell process, so I wouldn’t expect changing the settings to do anything given that it seems to be an issue with how Julia runs in PowerShell/cmd rather than with Juno.

1 Like

This doesn’t work like you’d expect anywhere (be it plain Powershell or Linux): You can “select” text with Shift-Left/Right, but that’s a different kind of selection from what you get from using the mouse; the first kind is a shell-based selection whereas the second one is terminal-based.

If shell decides whether one can select text with shift left/right, is it correct to infer that julia uses a different shell in linux than windows?

Googling this is hard for me because shell is associated with ; as well.