Repl immediately crashes in VSCode

Hi, when opening Julia from the command palette (Julia: start REPL) it immediately crashes/closes too fast for me to see any errors. I followed the FAQ at FAQ · Julia in VS Code to use Julia: Connect external repl which gives the following:

slwu89@pop-os:~$ julia
   _       _ _(_)_     |  Documentation:
  (_)     | (_) (_)    |
   _ _   _| |_  __ _   |  Type "?" for help, "]?" for Pkg help.
  | | | | | | |/ _` |  |
  | | |_| | | | (_| |  |  Version 1.9.1 (2023-06-07)
 _/ |\__'_|_|_|\__'_|  |  Official release
|__/                   |

julia> pushfirst!(LOAD_PATH, raw"/home/slwu89/.var/app/com.visualstudio.code/data/vscode/extensions/julialang.language-julia-1.47.2/scripts/packages");using VSCodeServer;popfirst!(LOAD_PATH);VSCodeServer.serve(raw"/tmp/vsc-jl-repl-c53b3d77-2a6b-4fc3-8a1c-bea3c10c67b4"; is_dev = "DEBUG_MODE=true" in Base.ARGS, crashreporting_pipename = raw"/tmp/vsc-jl-cr-613900b3-26d0-4067-8760-f50cb581d336");nothing # re-establishing connection with VSCode
[ Info: Precompiling VSCodeServer [9f5989ce-84fe-42d4-91ec-6a7a8d53ed0f]
ERROR: IOError: connect: no such file or directory (ENOENT)
 [1] wait_connected(x::Base.PipeEndpoint)
   @ Sockets ~/.julia/juliaup/julia-1.9.1+0.x64.linux.gnu/share/julia/stdlib/v1.9/Sockets/src/Sockets.jl:528
 [2] connect
   @ ~/.julia/juliaup/julia-1.9.1+0.x64.linux.gnu/share/julia/stdlib/v1.9/Sockets/src/Sockets.jl:563 [inlined]
 [3] connect
   @ ~/.julia/juliaup/julia-1.9.1+0.x64.linux.gnu/share/julia/stdlib/v1.9/Sockets/src/PipeServer.jl:103 [inlined]
 [4] serve(args::String; is_dev::Bool, crashreporting_pipename::String)
   @ VSCodeServer ~/.var/app/com.visualstudio.code/data/vscode/extensions/julialang.language-julia-1.47.2/scripts/packages/VSCodeServer/src/VSCodeServer.jl:110
 [5] top-level scope
   @ REPL[1]:1

I’m using juliaup to manage my Julia installs (version 1.9.1), on VSCode version 1.78.2, Julia VSCode extension version v1.47.2, and am running Pop!_os (installed VSCode as flatpak from the Pop!_Shop app manager). Also in my settings.json file for the Julia VSCode extension, my julia.executablePath is set correctly to the one managed by juliaup. If anyone has any ideas how I can fix this problem, I would greatly appreciate it.

1 Like

I’m confused. Why are you using the external REPL?

Try running (VS) Code natively, without Flatpak.


Because that is the only way I can see any error messages. As I explained in my post, when I use the standard Julia: start REPL it crashes too fast to see any errors.

1 Like

Thanks for the suggestion, that worked! Can you explain why that would work? The strange thing is that 2 days ago my previous setup (Flatpak) worked fine, and yesterday I suddenly experienced the problem I described, seemingly without any changes to my system.

Software packaged with Flatpak is subject to “sandboxing”, restricting it’s access to the host system (as configured by the packager).

A misconfiguration can cause the Flatpak-packaged software to have less capabilities than necessary, though.

Another possibility is disagreement between the security model assumed by the packagers and the one assumed by the software developers, also causing breakage for the user.

1 Like

Thanks for the explanation.