REPL extremely slow


#1

I installed atom and juno plugins, and the REPL console subwindow is very slow at scrolling and everything related, such as executing new commands there. A key/mouse press is reflected only after a few seconds. All other panels work fine, and an almost equivalent installation at another computer (both have i3 as window manager and similar overall setup) is fast even for REPL. I didn’t use atom before, so it’s a fresh installation. Any ideas how to track and fix the cause of slow REPL?


#2

My recommendation is to just use i3 instead of atom. If you already use i3, why do you need a program like atom to emulate its workflow? When i switched to i3, i completely ditched atom.


#3

What do you mean? i3 is a window manager, atom is an ide - how are they related?


#4

With the Julia REPL and vim editor and i3, the setup is basically same as atom IDE, except faster since it doesnt require electron. Vim plugins give me auto completion, etc.

I guess if you dont use vim, then maybe not.


#5

Please don’t derail the thread like this. The question was about Atom being slow and talking about how Vim can also do autocompletion is completely unhelpful and unrelated.


#6

I’m sorry you see it as unrelated, but based on my experience, it is very related. The OP specifically mentions i3, so it is a relevant work around and can solve the problem of sluggish response time


#7

Is Atom slow by default (i.e. with no plugins installed) or is it only after adding juno & co?


#8

It is not that “atom is slow”, only the REPL panel is slow! Code editing, for example, works fine.


#9

Try the Fallback Renderer option in the julia-client settings:
image

I’ll add a FAQ entry to increase visibility for that. In theory we could also detect this happening and open a popup (like VSCode does), but I haven’t yet found the time to implement that.

As to why this happens: The default REPL terminal renderer in Atom heavily relies on good GPU support, so minor hiccups your graphics driver might have (e.g. an improper setup, or just your laptop going to sleep and waking up again sometimes) might cause drastic performance issues.


#10

It turned out the issue was somehow related to me installing atom through snap. Now I installed it from downloadable deb package from the website and everything works ok regarding performance. Of course, this way I lose auto updating, but this is less of an issue.