Problem with Julia-client update to Atom

This morning I applied the Julia-client update (to 0.10.1) to Atom 1.40.1.

At first, Julia was then missing from Atom altogether. I followed the Juno FAQ instructions to

apm uninstall julia-client
(It failed, said some json was missing, as if it weren’t installed at all)
apm install julia-client
(Appeared to succeed)

Now the environment seems to work, but in the course of using the editor, I am now seeing messages like these every few seconds.

┌ Warning: Atom.jl: unrecognised message outline.
└ @ Atom C:\Users\brad\.julia\packages\Atom\Wouyw\src\comm.jl:171

I can’t be sure what action is causing them - they seemed random - at first I thought it was the mouse wheel.

I have figured out one way to reproduce them - it’s not the only cause, though - i’ts just one of the things that causes it. I can reproduce the warning by just clicking between the different tabs of the editor - a warning appears each time I change tabs. But is also seems to occur just while typing in the editor window.

At the moment, I don’t notice any other bad behavior other than these warnings.

I have tried completely closing all my editor tabs and closing Atom and starting over, but the errors recur.

Is this a new bug, or a sign of something wrong with my install?

Does anyone know what it means or how to fix it? It’s a bit hard to work with, as my REPL window overflows with these things and my work scrolls off the screen.

Had the same problem. Solved it by upgradeing Atom it self to (1.40.1), closing all atom windows and using the comandline:

apm update

apm uninstall ink
apm uninstall julia-client
apm install ink
apm install julia-client

which is basically what @pfitzseb suggestet in this post and you did as well… hm …

Thanks for the help. I tried your more extended script (including the update and ink:

apm update

apm uninstall ink
apm uninstall julia-client
apm install ink
apm install julia-client

Same results. Once you “Press Enter to Start Julia”, these messages start showing up in the REPL:

┌ Warning: Atom.jl: unrecognised message outline.
└ @ Atom C:\Users\brad\.julia\packages\Atom\Wouyw\src\comm.jl:171

Ah, wait - the link had some good info!

SOLUTION: Update Atom in the package manager

I checked, and my environment was still on Atom v.0.9.1

I went into package manager and did “update Atom” and the problem appears fixed!

Thanks for the link!

1 Like

The next Juno release will check what version of Atom.jl you have installed and notify you if it’s incompatible.
Sorry for the inconvenience.

1 Like

That’s great! I always forget to update Atom.jl.

I still have the problem, even with a clean Atom.

$ mv .atom .atom.bak # clean atom
$ atom --version
Atom    : 1.40.1
Electron: 3.1.10
Chrome  : 66.0.3359.181
Node    : 10.2.0
$ julia --version
julia version 1.2.0
$ apm install uber-juno
Installing uber-juno to /home/user/.atom/packages ✓
$ atom
$ apm list
Community Packages (7) /home/user/.atom/packages
├── indent-detective@0.4.0
├── ink@0.11.0
├── julia-client@0.10.1
├── language-julia@0.19.1
├── latex-completions@0.3.6
├── tool-bar@1.1.12
└── uber-juno@0.2.0

This is what solved the problem for me, to clean my local julia conf by issuing

$ mv .julia .julia.bak

Excuse me, do you know how to do this is Windows? As Im having the same problem even with a clean Atom.
Thanks

I think mv just renames the .julia folder to .julia.bak, so should be the same as nuking or renaming .julia in your C:\Users\yourusername directory

Look for the file “Atom.jl” in your user directory. On a Linux system it is found at ~/.julia/packages/Atom/<hash>/src/Atom.jl, where <hash> seems to be a short hash to identify the version being used or something alike.

I had a similar issue and solved it by updating Julia from 1.1.1 to 1.2.0