Warning: Atom.jl: unrecognised message `cacheCompletions`

Hi,
When I start Julia in Atom, I get the following warning. ‘julia-client’ and all the packages are up to date. I just updated it earlier today. After the update, I tried to run an example from the repo, but I couldn’t as atom/julia got stuck and didn’t gave me anything (no warnings/errors/results/updates). Later when I quit julia and started it again, I got the folllowing warning.

Starting Julia…
_
_ _ ()_ | Documentation: https://docs.julialang.org
() | () () |
_ _ | | __ _ | Type “?” for help, “]?” for Pkg help.
| | | | | | |/ ` | |
| | |
| | | | (
| | | Version 1.0.5 (2019-09-09)
/ |_|||_’_| | Official https://julialang.org/ release
|__/ |

julia> ┌ Warning: Atom.jl: unrecognised message cacheCompletions.
│ Please make sure your Atom and Julia packages are in sync.
│ - Try using Pkg; Pkg.update() to update this package.
│ - Check for julia-client updates in Atom.
└ @ Atom C:\Users\kavit.julia\packages\Atom\cYxbS\src\comm.jl:175

These are the installed packages
julia> Pkg.installed()
Dict{String,Union{Nothing, VersionNumber}} with 11 entries:
“CSV” => v"0.5.26"
“GLPK” => v"0.12.1"
“Atom” => v"0.12.9"
“ZipFile” => v"0.8.4"
“SDDP” => v"0.3.1"
“CPLEX” => v"0.6.3"
“Juno” => v"0.8.1"
“JuMP” => v"0.21.1"
“MathProgBase” => v"0.7.8"
“Dates” => nothing
“MathOptInterface” => v"0.9.12"

Any help will be greatly appreciated!!!

1 Like

Did you do execute:

using Pkg; Pkg.update()

Then restart the tray?

Thanks @pixel27 for your response.

Yes, I did try Pkg.update(). All the packages are up to date. julia-client in atom is also up to date. I’m not sure what is causing the error.

New user here, just updated Julia from 1.3 to 1.4 and changed the juliaPath in a config.cson accordingly, and I see the same error message. Weirdly it doesn’t show up when I start Julia the first time after opening Atom, but when I start Julia after stopping Julia at least once.

What version of Atom.jl and julia-client do you have installed?

I have the same problem. did you find a solution to it?

Make sure to update the Atom package julia-client (might require an Atom update, if you’re using an old version), as indicated in the warning.

1 Like