LoadError: unknown package Atom when trying to use Julia on Atom


#1

Hi,

I wanted to use Julia 0.6.2 on Atom, but I got the following error message when the uber-juno installation was ready:

Press Enter to start Julia.
Starting Julia...
juno-msg-installingjuno-msg-installERROR: LoadError: unknown package Atom
macro expansion at .\pkg\entry.jl:53 [inlined]
(::Base.Pkg.Entry.##1#3{String,Base.Pkg.Types.VersionSet})() at .\task.jl:335
Stacktrace:
[1] sync_end() at .\task.jl:287
[2] macro expansion at .\task.jl:303 [inlined]
[3] add(::String, ::Base.Pkg.Types.VersionSet) at .\pkg\entry.jl:51
[4] (::Base.Pkg.Dir.##4#7{Array{Any,1},Base.Pkg.Entry.#add,Tuple{String}})() at .\pkg\dir.jl:36
[5] cd(::Base.Pkg.Dir.##4#7{Array{Any,1},Base.Pkg.Entry.#add,Tuple{String}}, ::String) at .\file.jl
:59
[6] #cd#1(::Array{Any,1}, ::Function, ::Function, ::String, ::Vararg{String,N} where N) at .\pkg\di
r.jl:36
[7] add(::String) at .\pkg\pkg.jl:117
[8] include_from_node1(::String) at .\loading.jl:576
[9] include(::String) at .\sysimg.jl:14
[10] process_options(::Base.JLOptions) at .\client.jl:305
[11] _start() at .\client.jl:371
while loading C:\Users\mra136\.atom\packages\julia-client\script\boot_repl.jl, in expression starting
on line 11

Also if I now try to run Pkg.update() from Julia command prompt, the following error occurs:

ERROR: KeyError: key "Atom" not found
Stacktrace:
[1] getindex at .\dict.jl:474 [inlined]
[2] resolve(::Dict{String,Base.Pkg.Types.VersionSet}, ::Dict{String,Dict{Versio
nNumber,Base.Pkg.Types.Available}}, ::Dict{String,Tuple{VersionNumber,Bool}}, ::
Dict{String,Base.Pkg.Types.Fixed}, ::Dict{String,VersionNumber}, ::Set{String})
at .\pkg\entry.jl:485
[3] update(::String, ::Set{String}) at .\pkg\entry.jl:461
[4] (::Base.Pkg.Dir.##4#7{Array{Any,1},Base.Pkg.Entry.#update,Tuple{String,Set{
String}}})() at .\pkg\dir.jl:36
[5] cd(::Base.Pkg.Dir.##4#7{Array{Any,1},Base.Pkg.Entry.#update,Tuple{String,Se
t{String}}}, ::String) at .\file.jl:59
[6] #cd#1(::Array{Any,1}, ::Function, ::Function, ::String, ::Vararg{Any,N} whe
re N) at .\pkg\dir.jl:36
[7] update() at .\pkg\pkg.jl:228

Any suggestions why this happens and how to get this working?


#2

I’d recommend making a backup of C:\Users\mra136\.julia and then reinstalling Atom.jl and the other packages you need.


#3

Hi pfitzseb,
I’ve tried reinstalling Atom many times but I always get the same error.


#4

mrapo, just wondering if there’s a misunderstanding, as there’s some ambiguity in the above discussion. Many apologies if I’m saying something stupidly obvious. There’s Atom the program, and Atom.jl the Julia package (for interacting with Atom the program).

So I think what pfetzeb means is after backing up your .julia directory, delete it, and then open Julia (not in Atom, but seperately), and add the Atom.jl package

julia> Pkg.add("Atom")

And then open Atom.exe to see if that fixes the problem. Reinstalling Atom the program would not reset this directory, and so that would explain why you’re still having a problem.


#5

Hi haberdashPI and thanks for the explanation.

There is no Atom.jl folder inside the .julia folder.
If I run Pkg.add("Atom") i get an error that says ERROR: unknown package Atom.


#6

I believe you need to update your package Metadata:

julia>Pkg.update()

#7

I got Atom to work by reinstalling everything a few times, but now I cannot use, install or update any packages. I will create a new thread about it.