Error in Pkg.add:

pkg

#1

Hi everyone,

I just installed Julia (64 bit version) and Atom on Win 10, and I opened Atom with error below,

Press Enter to start Julia.
Starting Julia…
ERROR: LoadError: ArgumentError: Package Atom not found in current path:

  • Run Pkg.add("Atom") to install the Atom package.

Stacktrace:
[1] require(::Module, ::Symbol) at .\loading.jl:817
[2] top-level scope at C:\Users\Administrator.atom\packages\julia-client\script\boot_repl.jl:13
[3] include at .\boot.jl:317 [inlined]
[4] include_relative(::Module, ::String) at .\loading.jl:1038
[5] include(::Module, ::String) at .\sysimg.jl:29
[6] exec_options(::Base.JLOptions) at .\client.jl:229
[7] _start() at .\client.jl:421
in expression starting at C:\Users\Administrator.atom\packages\julia-client\script\boot_repl.jl:1

Then I open Julia terminal, and type Pkg.add("Atom")

ERROR: UndefVarError: Pkg not defined
Stacktrace:
[1] top-level scope at none:0

Can any one give help? Thanks a lot.

Ben


#2

Please try updating the julia-client package (ideally via closing Atom, opening a terminal and calling apm update) and try again.


#3

Aaah so that’s the way to do it without running into that weird bug where julia-client goes into zombie state!


#4

Yeah. I had kinda hoped I fixed that in the latest release but apparently not… Will look into it again sometime soon.


#5

It does not work,

julia> apm update
ERROR: syntax: extra token “update” after end of expression

julia> apm
ERROR: UndefVarError: apm not defined


#6

It does not work,

julia> apm update
ERROR: syntax: extra token “update” after end of expression
julia> apm
ERROR: UndefVarError: apm not defined

Any further suggestion?


#7

apm update is meant to be run in your terminal, not in a Julia session. Alternatively, you can also go in Atom into Preferences and there in the Updates tab to update your installed Atom packages.


#8

It does not work yet,

C:\WINDOWS\system32>apm update
Package Updates Available (0)
└── (empty)

Then

julia> Pkg.add(Atom)
ERROR: UndefVarError: Pkg not defined
Stacktrace:
[1] top-level scope at none:0

Any suggestion?


#9

Atom is terrible, not consolidated at all. People are wasting time updating and getting familiar with it. Not productive as RStudio, or PyCharm.


#10

I‘ve got similar problems to run Julia 1.0 using Atom 1.29.0. After a fresh installation of Atom and loading the package uber-juno (0.7.2) I tried to execute ‚1+1‘ within the console window (with julia-client setting Boot Mode: Cycler and Console Option: Legacy) I always get the error message:

ERROR: LoadError: UndefVarError: find_in_path not defined
Stacktrace:
 [1] getproperty(::Module, ::Symbol) at .\sysimg.jl:13
 [2] top-level scope at C:\Users\Carsten\.atom\packages\julia-client\script\boot_sync.jl:3
 [3] include at .\boot.jl:317 [inlined]
 [4] include_relative(::Module, ::String) at .\loading.jl:1038
 [5] include(::Module, ::String) at .\sysimg.jl:29
 [6] exec_options(::Base.JLOptions) at .\client.jl:229
 [7] _start() at .\client.jl:421
in expression starting at C:\Users\Carsten\.atom\packages\julia-client\script\boot_sync.jl:1

Using the Console Option: REPL-based ‚1+1 is works as expected.


#11

Sorry for that, should be fixed on the latest julia-client release. I’d emphatically urge you to start using the REPL-based console instead of the legacy console.

Please remember that Juno is a community effort and not backed by a company. We still try our best to get you stable releases, but sometimes there are some minor hiccups. If you’ve enabled the Legacy console as well then please update julia-client and try again.


#12

Regarding my reply above:
I started Atom and the new julia-client release 0.7.3 was updated. After relaunching Atom the Julia item within the menu disappeared and I was not able to get this item anymore. In a next step I uninstalled Atom by deleting the following folders:

C:\Users\User Name\.atom
C:\Users\User Name\AppData\Local\atom

Then I installed Atom again including loading the package uber-juno. Now executing a simple ‘1+1’ works within the Legacy console mode but I’ve got the error message (non-recurring):

Julia Client – Internal Error 
UndefVarError: active_repl not defined 

#13

Yes, still have this issue: Julia 1.0 + latest Atom does not work…
Atom used to be the best editor for Julia. But What I’m getting now:

Press Enter to start Julia.

Hold on tight while we're installing some packages for you.
This should only take a few seconds...

ERROR: LoadError: ArgumentError: Package Pkg not found in current path:
- Run `Pkg.add("Pkg")` to install the Pkg package.

Stacktrace:
 [1] require(::Module, ::Symbol) at .\loading.jl:817
 [2] top-level scope at C:\Users\isandler\.atom\packages\julia-client\script\boot_repl.jl:15
 [3] include at .\boot.jl:317 [inlined]
 [4] include_relative(::Module, ::String) at .\loading.jl:1038
 [5] include(::Module, ::String) at .\sysimg.jl:29
 [6] exec_options(::Base.JLOptions) at .\client.jl:229
 [7] _start() at .\client.jl:421
in expression starting at C:\Users\isandler\.atom\packages\julia-client\script\boot_repl.jl:1

I tried everything, for the last three days… System is Windows 10, 64 bits…


#14

rolling back to Julia 0.6.4: now everything is working.


#15

This error is because you did not import Pkg before you ran Pkg.add("Atom")