Juno not showing error messages

juno

#1

New to julia, running into odd problem. In some cases, when I run commands in the console, I’m not getting errors. For example:

No errors, no feedback nothing.

Similarly, if I execute by highlighting and hitting “shift-return” in editor, I get a whirling gear for ever:

To be clear, I SOMETIMES get errors, like syntax errors:

In the Julia REPL, by contrast:

Suggestions? Using macOS, and Atom has loaded uber-juno 0.1.2, and julia-client 0.6.0.


#2

First thing to try here is probably Pkg.update() in the REPL.
If it doesn’t work afterwards, type using Atom in the REPL and if that works without any errors but Juno still doesn’t, paste the output of Pkg.status() in a gist or somewhere else.
(Probably unrelated, but maybe important: What version of atom-ink do you have installed?)


#3

@pfitzseb Thanks so much! Looks like it was actually atom-ink – I had 0.6 something and upgrading to 0.7 fixed it. Much appreciated!


#4

Great, glad you got it working now! :slight_smile: