Juliaup in PATH, but julia not in PATH

Just deleted Julia from my computer and reinstalled via juliaup. All seemed to work well, no issues installing or accessing juliaup from the shell, but for some reason I can’t access julia itself.

image

Anyone have any idea as to why this would be happening?

Thanks,

GW

And yes, I’ve restarted the shell many times.

What’s in your PATH?

How did you install juliaup? Can you access julialauncher?

What does juliaup status shows? (to be sure that the release version has been added)

Just /home/user/.juliaup/bin as it relates to julia or juliaup.

image

I’ve tried both using default and specifying the julia build (julia +release), neither seem to work.

What’s in that directory?

The binaries for juliaup and julialauncher, both of which are functional.

@mkitti Actually, yes…I can access julialauncher from the shell. I guess an easy fix would be to add an alias “julia” that points to julialauncher?

The normal setup routine for Juliaup should have placed a symlink julia to julialauncher into the /home/user/.juliaup/bin folder. So the real question is why that didn’t happen :slight_smile: Was there an error message during setup? How exactly did you install?

2 Likes

I am surprised, in my installations juliaup folder is not at the home directory but inside the .julia one. How did you get it and installed it? What is the version used?

This change a while ago, i.e. the current version now puts the julialauncher and juliaup binaries and julia symlink into a folder called ~/.juliaup by default, but the actual Julia versions still get installed into the depot, i.e. ~/.julia/juliaup. There is no need to change this for you, though, you can just stick with the installation you have.

1 Like

@jdad @davidanthoff Sorry guys, just having the realization now that I accidentally closed the terminal a few hours ago which I had assumed didn’t affect the installation process at all as when I reopened it, I could use juliaup just fine.

I’m guessing the routine finished everything except for creating that symlink…

1 Like

I would just do a juliaup self uninstall and then reinstall again and make sure you let it finish. If it still doesn’t work, could you copy everything it prints to the output and paste it here?

4 Likes

I can confirm that after doing juliaup self uninstall followed by curl -fsSL https://install.julialang.org | sh that julia was acessible via the PATH without any issues.

Sorry again for my own mistake.

4 Likes