Julia running in Git bash in Atom

The dysfunctional “shell” under Windows is a persistent pain point for me.
I asked for Julia to be started in the Git bash, but apparently that is too tricky.

It is good to have an idle half-an-hour :). I have something now that almost works.
An ugly hack? Perhaps. But it works to a large degree. In the Julia console in Atom, run

run(`"C:\\Program Files\\Git\\bin\\bash.exe" -exec julia`)

image

Now for the “large degree”: I get a functional Julia, but “Run block” or “Run file” do not work anymore :frowning: I guess those commands still try to communicate with the underlying Julia running in the “cmd”? Would it be possible to communicate instead with the Julia I just started in the bash?

I tried again the suggestion of @pfitzseb (https://github.com/JunoLab/atom-julia-client/issues/527), and this time it worked (I don’t know why, but previously I couldn’t get it to work. My fault, I’m sure.).

This is the solution: ignore the above naïve and clumsy attempt please.

Simply start Atom in the Git bash. That takes care of Julia starting in the bash automatically. And, at least so far, everything works: “Run block”, “Run file”, …

3 Likes