Julia -- problems with files on OneDrive?


#1

I’m currently testing some Julia code developed by others. Code that worked for the developers, didn’t work for me. It seems that the problem is that I have put the files on OneDrive. When I move files to the C-drive, the code works.

Question 1: is there a problem for Julia with files on OneDrive?
Question 2: if a problem, is there any chance this might be resolved?

Background: I use OneDrive to sync files between several computers. When Microsoft updated OneDrive to allow for links to off-line files in the Fall Creators Update in 2017, some code didn’t work. However, I resolved that by choosing to download all files.


#2

Seems you might have already done this.

I resolved a similar issue by disabling Files on Demand, from OneDrive settings.


#3

#4

Yes, I temporarily solved my problem with disabling Files on Demand. Now, I again have problems.

Oooooops – I just discovered that Microsoft has re-enabled Files on Demand in one of their updates!!

OK – I’ll check if disabling this solves the problem.


#5

No, I disabled (once again) Files on Demand, restarted Windows, and ran the test again. Still problems. So the problem is deeper than files on demand.


#6

OK – my understanding from this thread is that there is a bug in Julia - OneDrive interaction, and that the bug will be fixed. But it doesn’t say when it will be fixed, or whether it has been fixed. In any case, there is a problem now, so if the problem was fixed, Microsoft must have re-introduced a problem?? [I’m using the latest update of Windows 10, and the latest update of Julia v.0.6.2].


#7

I think https://github.com/JuliaLang/libuv/pull/47 needs to be merged.