Strange file open error on windows


#1

I got a file open error trying to access a file on a windows network drive.

julia said it could not open the file because the file does not exist, however the file DOES exist.

Now, the first time this happened windows was also giving me weirdness saying that the file didn’t exist when i tried to open it, but that’s since stopped.

so the first thing i thought was that the filename was too long. However i shortened the file name and still had the same problem.

So far i’ve had precisely one file (and there are a LOT of files on this network drive) do this. I did verify that the filename being handed back in the error message is the same filename that i tried to open. also i made sure to check for potentially invalid characters.

Does anybody have any ideas ??

Thanks!


#2

Try to obtain an MWE, along the lines of

filename = ...
write(filename, "testing")
read(filename, String)          # ERROR

with Windows version and all relevant details.


#3

Ok. Try to open the directory in which the file is located using Explorer. Keep the explorer window open and try again.


#4

Well it’s a weird windows problem.

I shortened the name of the file AND the containing directory (which was also very long) and the problem disappeared.

I suspect that the fact that it was a network drive contributed to the trouble in some way.

I would debug this if i thought it might be a julia issue, but considering that windows was giving us the same sort of trouble (my colleague tried to open the file with a different tool and ran into the same problem) i think i’ll just let it go.


#5

It is indeed related to Windows, particularly as the file is in network drive. I am having the same issue in other tools, including powershell and Excel VBA.


#6

Try mapping a drive letter to the network folder.