Julia 1.8.1 absolutely does not work in VSCode

I have tried uninstalling and reinstalling Julia 1.8.1, I have tried uninstalling and reinstalling VSCode, I have tried uninstalling and reinstalling the Julia extension in VSCode, I have checked that the settings.json file points to the right place. Julia is added to my PATH on Windows 10, there are no spaces in the file path, I am using escaped slashes (\)…

VSCode firstly fails to auto-create a julia file from the welcome page (clicking New File → Julia) - nothing happens. If I manually create a .jl file and type some code and instruct it to run with Ctrl+F5 - nothing happens. I can fire up the julia REPL and execute code that way.

Help, please.

Maybe some things to start checking…

Can the Julia in VSCode add-in find your Julia installation? Either Julia must be on the system path (or equivalent of you aren’t using Windows), or you installed Julia via JuliaUp or you explicitly specify the path in the extension settings.

Hello - thanks for reply!

Julia is on the system path (the full path to julia.exe) and both places where one can specify the path to julia in settings.json point to the same place (also the full path to julia.exe). Still doesn’t work.

So the fact that REPL works would suggest that Julia installation is ok.

Both of the actions you mentioned are just shortcuts (if I’m not mistaken).
Could you check in VSCode that those key combinations are connected to Julia actions?
Maybe some other extension hijacked them?


I checked the keybindings - and there are no collision.

I also disabled all of the other extensions except for Julia, and this is the error I get:

“Could not start the Julia language server make sure the ‘julia.ExecutablePath’ setting points to the Julia binary”

The setting points to C:\Users\USERNAME\AppData\Local\Programs\Julia-1.8.1\bin\julia.exe

I should also mention that I have gotten the above error before with other extensions enabled, so I do not think it is an extensions problem.

So I just checked and in my settings this field is empty.
Did you put it in manually? Does anything change when you delete the path?

Also does this happen with 1.8.1 specifically or with other Julia versions also?

I have not tried with other versions of Julia as I’m new to it - so the only version I have is 1.8.1

I did blank the field as well and I get the same error as above - VSCode tries to start the Julia language server 5 times in a row, fails repeatedly, then stops trying to do so.

This error: “Julia Language Server client: couldn’t create connection to server.”

So the only thing that comes to my mind is that for some reason VSCode does not have permission to read the folder with Julia.
Could you try to install it in some other folder (e.g. directly in your user folder) and see if that helps?


THAT WORKED! :smiley:

I installed Julia in my C:\Users\USERNAME\ folder and VSCode detected it straightaway. Ran a “Hello world!” script perfectly.

NGL - I’ve been tearing my hair out over this issue for the last day or so - so thank you again from keeping me from going completely bald! :smiley:


It seems that you cannot use juliaup any more.

I think Juliaup would actually prevent this problem as on my machine, different Julia versions live in:


which shouldn’t face the problem mentioned by OP.
If Juliaup does not work for you, please post about it in a separate topic.