Error `julia.environmentPath` on Linux


After a break I’ve installed new Julia 1.8.1 version on Ubuntu 20.04.5 LTS machine, set path variable, in terminal Julia works just fine, but in VS Code I’m getting untypical error

Could not start the Julia language server. Make sure the julia.environmentPath setting is valid.

I cannot find any sources what one can do with this. My path settings are pretty standard

“terminal.integrated.commandsToSkipShell”: [
“julia.symbolCacheDownload”: true,
“julia.executablePath”: “”,
“julia.environmentPath”: “”,

VS Code v1.71.2, Julia extension v1.7.12

Not an expert but I think that you can ignore setting julia.environmentPath, but it is more important to set julia.executablePath if VS Code is having trouble finding the julia executable for some reason: can you say whether or not you can launch an integrated REPL in VS Code?
Also, try manually setting your Julia environment by clicking on Julia env: ... on the bottom blue bar of the window?

In the terminal Julia works just fine, in the one integrated with VS Code too. The Julia env: ... is loading indefinitely, the error is Cannot read properties of undefined (reading 'file'). All of this is very confusing.

I would try opening VS Code Settings → Extensions → Julia, and under “Julia: Executable Path”, manually adding the path to julia, e.g. the result of whereis julia in the terminal.

It worked, thanks! Executable path was one of the first things I tried, but I have given soft link location, not the binary location. Only the binary location works. Strange.