Julia 1.0 IDE for Windows


#1

I was wondering if anyone has been working on Windows with Julia 1.0 and has had any positive experiences using an IDE.

  • The Visual Studio Code extension doesn’t support Julia 1.0 and definitely doesn’t work for Windows.
  • The Atom-based Juno-IDE isn’t doing any linting, which is kind of basic functionality I would expect from an IDE. Maybe I’m just using this tool incorrectly?
  • Jupyter Notebook is fine, but isn’t really an IDE.
  • I know how to use vim, but I’m really not fast with it. Consequently, I’m hesitant to use it with this language I just started learning.

#2

JupyterLab is more of an IDE, but there’s no linting.


#3

I’m not able to use Jupyter nor Visual Studio with Julia 1.0, I guess they are not compatible.


#4

@Juan ; Jupyter notebook is certainly compatible with Julia 1.0. Not sure about JupyterLab.


#5

I use the super fast sublime text 3 on windows. However, it’s probably not a full IDE


#6

The julia 1.0 compatible version 0.11.0-alpha of the VSCode-Pugin for julia has just been released. It has to be installed using the .vsix-file from that link until it will be released as stable version.

I have been using the master branch of the plugin for the last few weeks and 1.0 support is pretty good now.


Has anyone gotten VScode working with Julia 1.0?
#7

I updated vscode with this new extension and it gives out a crash message. I even tried uninstalling the old one and installing the new one but it doesnot help.


#8

Hi @Seanny123 I am a fan of Atom and use it on Windows 10.
There is a linter package for Julia: https://atom.io/packages/linter-julia
Please put a message on this thread if you have trouble installing it.
Oh, I use the Atom Beta version. I have never found any instability with that.


#9

No, Juno just doesn’t have an integrated Linter yet (although we do have Traceur.jl integration since the last release). Also see Is there currently any linter for Juno on 1.0+?.


#10

It seems to work for me, thanks.
I’m using VS Code 1.28.2 on Windows 10 X64.

PD: I’ve just tried on a different computer with Windows 7 with VS Code 1.29.0 and it also works. And I haven’t needed to create exclusion rules on the firewall nor antivirus nor anything strange.
I’ve just installed Julia as administrator and VS Code and cofigured the path por VS Code.

Should we install these things as user instead?
I don’t want to have privilege problems when compiling packages.

PD2:

Now I’ve tried to install the package Plots and I get this error:

julia> Pkg.build(“GR”)
Building GR → C:\Users\med\.julia\packages\GR\k8wwU\deps\build.log
┌ Error: Error building GR:
[ Info: Downloading pre-compiled GR 0.35.0 Windows binary
│ [ Info: Using insecure connection
│ [ Info: Cannot download GR run-time
│ ERROR: LoadError: IOError: chmod: no such file or directory (ENOENT)
│ Stacktrace:
│ [1] uv_error at .\libuv.jl:85 [inlined]
│ [2] #chmod#16(::Bool, ::Function, ::String, ::UInt16) at .\file.jl:829
│ [3] chmod at .\file.jl:828 [inlined]
│ [4] #rm#9(::Bool, ::Bool, ::Function, ::String) at .\file.jl:250
│ [5] rm(::String) at .\file.jl:245
│ [6] top-level scope at logging.jl:319
│ [7] top-level scope at C:\Users\med.julia\packages\GR\k8wwU\deps\build.jl:91
│ [8] include at .\boot.jl:317 [inlined]
│ [9] include_relative(::Module, ::String) at .\loading.jl:1044
│ [10] include(::Module, ::String) at .\sysimg.jl:29
│ [11] include(::String) at .\client.jl:392
│ [12] top-level scope at none:0
│ in expression starting at C:\Users\med.julia\packages\GR\k8wwU\deps\build.jl:63
└ @ Pkg.Operations
C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\Operations.jl:1097

I don’t know if it has anything to do.


#11

I am using vscode 1.29 on win10 x64. It crashes.


#12

It is definitely compatible. Could you report your error messages? As long as the jupyter kernal can see your julia installation and you have IJulia installed, it you should be able to select julia from the GUI.


#13

I installed VSCode as user and it works perfectly with the julia extension.


#14

0.11.0-alpha.8 also works well for me.

On Windows 10.


#15

I’m so relieved this works with both Intellisense and Linting!

GUI-like debugging would be nice too, but I understand it takes a while to develop. If it was easy, I would develop it myself!


#16

Even Fortran has a working language server now…


Really hope to see Julia gets better editor support.


#17

I am not sure what the “even” is supposed to imply here — Fortran is at least 3-4 decades older than Julia, and has a very large userbase.

I am confident that Julia will get a stable backend at some point, but the best way to make that happen is contributing to it.


#18

Julia also has a working language server. The alpha works fine for me. Did you try it?


#19

Which commit is the alpha release? I’m not seeing it here: https://github.com/JuliaEditorSupport/LanguageServer.jl/releases.


#20

The VSCode release is https://github.com/JuliaEditorSupport/julia-vscode/releases which probably uses a recent commit of LanguageServer.jl