Problem installing JuliaPro on Linux Mint 19.1


I am getting back to Julia after years of non-usage. I’ve tried to install JuliaPro on my Linux Mint 19.1 (ie, a flavor of Ubuntu 18.04) desktop using the following steps:

  • Using root account:
    • Created: sudo /usr/lib/julia
    • Set permissions: sudo chmod a+wrx /usr/lib/julia
  • Using my default user:
    • Succesfully installed juliapro as indicated in the quick start guide: ./ /usr/lib/julia

Atom seems to open after issuing: /usr/lib/julia/JuliaPro-1.2.0-1/Launch_JuliaPro but the interface I see is completely different from the ones illustrated in the quick guide and it does not seem to contain any julia-specific menu items.

Moreover, error messages are reported in the shell:
$ ./Launch_JuliaPro
bash: cannot set terminal process group (-1): Inappropriate ioctl for device
bash: no job control in this shell
Gtk-Message: 08:26:39.248: GtkDialog mapped without a transient parent. This is discouraged.

Any ideas?

Thanks in advance

Can you please compare the contents between following folders


They should be exactly the same, if they are not, then please copy the contents of /usr/lib/julia/JuliaPro-1.2.0-1/JuliaPro-Juno-1.2.0-1/julia_atom_1.2.0-1 onto $HOME/.julia_atom_1.2.0-1 , this should solve the issue.

Just a FYI:- You don’t need to install JuliaPro with root privileges, you can install JuliaPro as a non-admin user too.

1 Like

That worked.