Installation in Windows 10 - access is denied - how to fix?

I am in fact not new to Julia, but I am just now trying to install version 1.7.1 on a new machine with a new installation of Windows 10. I downloaded and ran the installer, which added the julia “bin” directory to the path. This meant I could open up a command prompt, type “julia” at the command - and I was away.

My first order of business was to install IJulia, which I did with use Pkg; Pkg.install("IJulia") and this seemed to go fine. But then I found myself not back in Julia, or in its package subsystem, but at the command prompt. And when I entered julia again at the prompt I was told that “Access is denied”.

I have no idea why adding IJulia should make julia inaccessible, but this seems to be what’s happened. Does anybody know how to fix this? How can I access julia again, and also install IJulia?

Thank you!

When I tried in Windows PowerShell instead of the Command Prompt, I got this error message:

Program 'julia.exe' failed to run: Access is deniedAt line:1 char:1
+ julia
+ ~~~~~.
At line:1 char:1
+ julia
+ ~~~~~
    + CategoryInfo          : ResourceUnavailable: (:) [], ApplicationFailedException
+ FullyQualifiedErrorId : NativeCommandFailed

I’m still mystified!

Does julia.exe still exist where you expect it to be ?

Do you have admin rights? Corporate Policy sometimes kicks in and ruins your day.

Thanks for your reply! Yes indeed julia.exe is in the same place, which is in my path, and I’ve checked its folder tree, and all of them have user read/write access (well, I just went with the default, which installs julia in the user’s home directory).

Curiously enough, after a while it seems to come good again; that is, when I choose “Julia 1.7.1” in my start menu I get a command window containing the julia REPL. However - if I attempt to install IJulia, I wreck it and it becomes unusable. Anyway, I’ve just checked with Pkg.status() and it seems that IJulia is installed, and when I attempted"IJulia") it didn’t complain. So I’m going to tentatively assumed I’ve crossed that particular bridge…

Thank you again!

I’m convinced that the very act of my asking a question, and somebody answering - even if I’ve already solved my own problem - is essential. So don’t imagine you did nothing! You probably jogged the universe’s elbow in some way, so enabling me to move forward…

I’m happy to be your rubber duckie

1 Like

Join the queue of about half the internet…!

1 Like