Add IJulia Error


#1

I try to install Ijulia for several days, and this is the error I receive.
what to do to achieve it?
Gracias
Note: I have Anaconda3 and Python 3.7 installed!

               _
   _       _ _(_)_     |  Documentation: https://docs.julialang.org
  (_)     | (_) (_)    |
   _ _   _| |_  __ _   |  Type "?" for help, "]?" for Pkg help.
  | | | | | | |/ _` |  |
  | | |_| | | | (_| |  |  Version 1.0.2 (2018-11-08)
 _/ |\__'_|_|_|\__'_|  |  Official https://julialang.org/ release
|__/                   |

(v1.0) pkg> add IJulia
  Updating registry at `C:\Users\hermesr\.julia\registries\General`
  Updating git-repo `https://github.com/JuliaRegistries/General.git`
 Resolving package versions...
 Installed GenericSVD ─ v0.2.1
 Installed LazyArrays ─ v0.5.0
 Installed PDMats ───── v0.9.6
 Installed IJulia ───── v1.14.1
 Installed CodeTools ── v0.6.3
  Updating `C:\Users\hermesr\.julia\environments\v1.0\Project.toml`
  [7073ff75] + IJulia v1.14.1
  Updating `C:\Users\hermesr\.julia\environments\v1.0\Manifest.toml`
  [53a63b46] ↑ CodeTools v0.6.2 ? v0.6.3
  [01680d73] ↑ GenericSVD v0.2.0 ? v0.2.1
  [7073ff75] + IJulia v1.14.1
  [5078a376] ↑ LazyArrays v0.4.0 ? v0.5.0
  [90014a1f] ↑ PDMats v0.9.5 ? v0.9.6
  [b85f4697] + SoftGlobalScope v1.0.7
  [c2297ded] + ZMQ v1.0.0
  Building IJulia → `C:\Users\hermesr\.julia\packages\IJulia\DL02A\deps\build.lo
g`
┌ Error: Error building `IJulia`:
│ Solving environment: ...working... done
│
│ # All requested packages already installed.
│
│ Error executing Jupyter command 'kernelspec': [Errno 'jupyter-kernelspec' not
found] 2
│ [InstallKernelSpec] Removing existing kernelspec in C:\Users\hermesr\AppData\R
oaming\jupyter\kernels\julia-1.0
│ [WinError 5] Access is denied: 'C:\\Users\\hermesr\\AppData\\Roaming\\jupyter\
\kernels\\julia-1.0\\logo-32x32.png'
│ [ Info: Installing Jupyter via the Conda package.
│ [ Info: Running `conda install -y jupyter` in root environment
│ [ Info: Found Jupyter version 4.4.0: C:\Users\hermesr\.julia\conda\3\Scripts\j
upyter
│ [ Info: Installing Julia kernelspec julia-1.0
│ ERROR: LoadError: failed process: Process(`'C:\Users\hermesr\.julia\conda\3\py
thon.exe' 'C:\Users\hermesr\.julia\conda\3\Scripts\jupyter-kernelspec-script.py'
 install --replace --user 'C:\Users\hermesr\AppData\Local\Temp\julia-1.0'`, Proc
essExited(1)) [1]
│ Stacktrace:
│  [1] error(::String, ::Base.Process, ::String, ::Int64, ::String) at .\error.j
l:42
│  [2] pipeline_error at .\process.jl:705 [inlined]
│  [3] #run#504(::Bool, ::Function, ::Cmd) at .\process.jl:663
│  [4] run at .\process.jl:661 [inlined]
│  [5] #installkernel#4(::String, ::Function, ::String) at C:\Users\hermesr\.jul
ia\packages\IJulia\DL02A\deps\kspec.jl:85
│  [6] installkernel(::String) at C:\Users\hermesr\.julia\packages\IJulia\DL02A\
deps\kspec.jl:36
│  [7] top-level scope at logging.jl:308
│  [8] top-level scope at logging.jl:307
│  [9] top-level scope at C:\Users\hermesr\.julia\packages\IJulia\DL02A\deps\bui
ld.jl:41
│  [10] include at .\boot.jl:317 [inlined]
│  [11] include_relative(::Module, ::String) at .\loading.jl:1044
│  [12] include(::Module, ::String) at .\sysimg.jl:29
│  [13] include(::String) at .\client.jl:392
│  [14] top-level scope at none:0
│ in expression starting at C:\Users\hermesr\.julia\packages\IJulia\DL02A\deps\b
uild.jl:9
└ @ Pkg.Operations C:\cygwin\home\Administrator\buildbot\worker\package_win32\bu
ild\usr\share\julia\stdlib\v1.0\Pkg\src\Operations.jl:1097

(v1.0) pkg>

#2

Might be some clues here:


#3

Sounds like the C:\Users\hermesr\AppData\Roaming\jupyter\\kernels directory doesn’t have write permissions for you for some reason?


#4

I’m also getting the same error on a clean AppVeyor build: https://ci.appveyor.com/project/rdeits/dynamicwalking2018-jl/builds/20393318/job/8avwvbnj67shd7sf#L172


#5

I have faced the same issue sometime back. I deleted the files in the folder and rebuilt IJulia and it worked.


#6

Please, argue a little more.
What files do you delete?
Within what folder?
Gracias


#7

I deleted this Jupyter folder and then rebuilt IJulia.

'C:\Users\hermesr\AppData\Roaming\jupyter\


#8

You can also check if you have the write permission to this folder. As mentioned by @stevengj, the issue occurs if Julia is not able to update files in the specified folders shown in the error log.


#9

Removing Julia-1.0 folder under this structure and then rebuilding IJulia also works.


#10

How do I perform this check?


#11

For Windows 10.

Select the folder and do right click on the mouse. A context menu appear. Look at the Read-only check box in General Tab. If it is un-ticked, it is not read-only. Else it could be partial or total read-only. Go to Security Tab and look at the various permissions to find out.

If you have proper rights on the system, you can try un-checking the box in general tab and click apply.
Hope it will solve the issue of write permission.


#12

Thank you very much, IJulia is already running on my PC !!!
I have the following file:
C: / Users / hermesr / Documents / Julia software / Julia Notebooks / IJulia Preview.ipynb
As I do to execute it, what differences are there between IJulia.load () and notebook ()?


#13

I start jupyter notebook from windows cmd terminal by using the command ‘jupyter notebook’.

AFAIK this procedure is similar to starting jupyter notebook using ‘notebook()’ command from Julia REPL. And for this to work you need to issue ‘using IJulia’ command on the Julia REPL before the notebook() command.


#14

in this way I was able to access the ipynb files in the desired folder

julia>using IJulia
julia>notebook(dir="C:/Users/hermesr/Documents/Julia software/Julia Notebooks")