Cannot run Julia after trying to install packages

I am working on a university desktop computer which runs on Windows 10 Enterprise.

I am set as administrator.

I can download, install and run Julia after installation. When I attempt to install any package, the process starts, but then the program gets killed before it finishes. After this happens I am no longer able to run Julia and get the following message from Windows: “Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item.”

This happens whether I double click it or right-click + “Run as Administrator”. If I uninstall Julia, erase all trace of it, and then re-install it the installation completes but the same problem persists (cannot run the program).

If I turn the computer off and come back the next day I am able to go back to square 1 (can run Julia and do operations like 2+2 but the same happens once I try to install packages), regardless of having previously uninstalled Julia or not.

I have tried getting help from the IT department but they do not seem to know what is going on either. If I could get some specific things I could ask to the IT guys from here that would be fantastic.

Thanks.

Hard to diagnose but sounds like some antivirus is deleting / removing your Julia.exe?

2 Likes

Thanks for the quick response.

The Julia.exe file is still there in the default folder. When I try to double click on it or run as administrator is when I get the issue.

For debugging: start your preferred shell (or PowersHell if you don’t have access to that), and run Julia as julia. Install a package. See if there is any error printing.

Does Julia end up stuck in your task manager? (Ctrl+alt+delete). If you kill it, can you then start it again?

Is waiting a day necessary? Is logging out sufficient?

1 Like

And don’t run Julia as administrator. That’s a nuclear option. Windows’ permission system is strange, so I’m not sure what it does and does not allow, but you generally don’t want to be elevating something as powerful as a general scripting language.

1 Like

@cesquivea Welcome to Julia. I run Julia on Windows also. Please do not get frustrated.
we will help you here - we often see people having problems at the beginning. Please, please do not quit in frustration.

To help you, I would advise doing one of two things:
a) look in the Windows Store app for Julia - there is a new Julia installation program called juliaup
b) Look at the Chocolatey package manager which also can install and update Julia for you

In the past I have always recommended Chocolatey, but the new juliaup looks good too.

Please try either of these and tell us your progress.
There was an issue in the past with Windows regarding the permissions which a user has - I cant quit remember what the exact issue or setting was. I thought this had been solved anyway. Maybe some searching will bring it up.

1 Like

@cesquivea Hello! What is the status of your Julia installation?

Hi John,

Thanks for your help. Downloading it from the Windows Store did not work either. The problem seems to be that Julia was setting off false positives as possible ransomware (this is what the IT person from my institution told me). He added Julia to a whitelist in the antivirus and now it all works.

In case this is useful, the antivirus is Cysco AMP for endpoints connector.

Best,
Carlos

1 Like

Thankyou - this is good to hear. Perhaps someone else will have the same problem and we can remember the fix!

Same thing is happening also on my working laptop, I have the impression as well that it is a problem related to antivirus/malware…

Edit: Confirmed that in my case it’s due to the antivirus (CiscoAMP) flagging the executable as ransomware when adding/installing packages (probably due to fast disk writes?)

2 Likes

The only real recourse is to report this to the antivirus provider as a false positive.