Failure to precompile Plots.jl in Linux

Hi, I have trouble to precompile Plots.jl in Linux. I looked through a couple of similar questions but my problem still can not be solved. Any help will be appreciated. Below is the error msg and environment info:

julia> using Plots
[ Info: Precompiling Plots [91a5bcdd-55d7-5caf-9e0b-520d859cae80]
Invalid instruction at 0x7f9bc363e9e3: 0xc4, 0xc1, 0x7b, 0x92, 0xce, 0xc5, 0xf9, 0x28, 0xc4, 0x62, 0xf1, 0xff, 0x09, 0x10, 0xc5
[742125] signal (4.2): Illegal instruction
in expression starting at /nas/longleaf/home/fengyu/.conda/envs/julia_env1/share/julia/packages/Plots/sxUvK/src/components.jl:103
_linspace at ./twiceprecision.jl:0
range_start_stop_length at ./twiceprecision.jl:668
_range at ./range.jl:161 [inlined]
#range#70 at ./range.jl:142 [inlined]
range at ./range.jl:142 [inlined]
partialcircle at /nas/longleaf/home/fengyu/.conda/envs/julia_env1/share/julia/packages/Plots/sxUvK/src/components.jl:46 [inlined]
#makeshape#155 at /nas/longleaf/home/fengyu/.conda/envs/julia_env1/share/julia/packages/Plots/sxUvK/src/components.jl:75 [inlined]
makeshape at /nas/longleaf/home/fengyu/.conda/envs/julia_env1/share/julia/packages/Plots/sxUvK/src/components.jl:75
unknown function (ip: 0x7f9bc452c71a)
jl_apply at /usr/local/src/conda/julia-1.9.3/src/julia.h:1880 [inlined]
do_call at /usr/local/src/conda/julia-1.9.3/src/interpreter.c:126
eval_value at /usr/local/src/conda/julia-1.9.3/src/interpreter.c:226
eval_stmt_value at /usr/local/src/conda/julia-1.9.3/src/interpreter.c:177 [inlined]
eval_body at /usr/local/src/conda/julia-1.9.3/src/interpreter.c:606
jl_interpret_toplevel_thunk at /usr/local/src/conda/julia-1.9.3/src/interpreter.c:762
jl_toplevel_eval_flex at /usr/local/src/conda/julia-1.9.3/src/toplevel.c:912
jl_toplevel_eval_flex at /usr/local/src/conda/julia-1.9.3/src/toplevel.c:856
ijl_toplevel_eval_in at /usr/local/src/conda/julia-1.9.3/src/toplevel.c:971
eval at ./boot.jl:370 [inlined]
include_string at ./loading.jl:1903
include_string at ./loading.jl:1913 [inlined]
exec_options at ./client.jl:305
_start at ./client.jl:522
jfptr__start_32224.clone_1 at /nas/longleaf/home/fengyu/.conda/envs/julia_env1/lib/julia/ (unknown line)
jl_apply at /usr/local/src/conda/julia-1.9.3/src/julia.h:1880 [inlined]
true_main at /usr/local/src/conda/julia-1.9.3/src/jlapi.c:573
jl_repl_entrypoint at /usr/local/src/conda/julia-1.9.3/src/jlapi.c:717
main at /home/conda/feedstock_root/build_artifacts/julia_1693156704872/work/cli/loader_exe.c:59
__libc_start_main at /lib64/ (unknown line)
_start at /nas/longleaf/home/fengyu/.conda/envs/julia_env1/bin/julia (unknown line)
Allocations: 2791919 (Pool: 2790224; Big: 1695); GC: 4
ERROR: Failed to precompile Plots [91a5bcdd-55d7-5caf-9e0b-520d859cae80] to "/nas/longleaf/home/fengyu/.conda/envs/julia_env1/shar
 [1] error(s::String)
   @ Base ./error.jl:35
 [2] compilecache(pkg::Base.PkgId, path::String, internal_stderr::IO, internal_stdout::IO, keep_loaded_modules::Bool)
   @ Base ./loading.jl:2300
 [3] compilecache
   @ ./loading.jl:2167 [inlined]
 [4] _require(pkg::Base.PkgId, env::String)
   @ Base ./loading.jl:1805
 [5] _require_prelocked(uuidkey::Base.PkgId, env::String)
   @ Base ./loading.jl:1660
 [6] macro expansion
   @ ./loading.jl:1648 [inlined]
 [7] macro expansion
   @ ./lock.jl:267 [inlined]
 [8] require(into::Module, mod::Symbol)
   @ Base ./loading.jl:1611

Environment info:
Julia Version 1.9.2
Plots v1.39.0
Commit e4ee485e90 (2023-07-05 09:39 UTC)
Platform Info:
OS: Linux (x86_64-conda-linux-gnu)
CPU: 14.0.6 (ORCJIT, znver3)
Threads: 1 on 64 virtual cores

1 Like

Could you please try downloading Julia from Download Julia or use juliaup via curl -fsSL | sh?

While I have tried my best to make the julia in conda work, it is terribly complicated. As such the first thing to try is to download Julia from official sources.


Thanks for your quick reply! Do you know any way to install Julia without sudo permission? I am running codes on a cluster without sudo permission. That’s why I installed julia in conda

1 Like

Neither of the above methods require sudo. The first is just a tarball than you can untar. The second will install julia in your home folder.


Thank you! Now the issue is solved. Time to see farewell to conda.

1 Like