Unable to precompile Plots

Hi all,
I am unable to precompile the package Plots due to the following error:

The following remedies have been attempted but so far none have been successful:
-Uninstalling and reinstalling Julia
-Adding and building GR
-Building Plots
-Trying an older version of Julia
It would be great if someone could offer a solution to this issue.
A screenshot of the error message is attached for reference.

Thanks in advance.

Hi, do you try to use Julia with admin priviledge ?

What happens if you remove (or rename) the C:\Users\HP\.julia folder and try again?

Would selecting ‘Run as administrator’ when selecting Julia be sufficient? I did this just now but still got the same error.
My PC is running on Windows 10 Home.

Thanks for the suggestion however this didn’t resolve the issue.

I just tried this and can’t replicate the error, installing Plots into a fresh environment under Julia 1.8.5 on Windows 10 worked just fine. Have you tried installing in a clean environment?

HI. I’m not sure how I could check if my environment is clean or not. Do I need to perform a clean install of the OS or do something similar?

No, @nilshg was alluding to a fresh Julia project environment as described here 4. Working with Environments · Pkg.jl

  1. Start Julia.
  2. Chose an empty folder for your new project.
  3. ] activate <projectfolder>
  4. add Plots

You will find a Project.toml and Manifest.toml in that folder afterwards.

See if the error persists.

Try emptying your compiled cache (it is likely in an inconsistent state). For example, if you’re using julia 1.8, I think this should be C:Users\HP\.julia\compiled\v1.8. Hopefully some variant of that path will work for you.

After you empty it, you’ll have to re-precompile every package on your system.

I had similar issues with Plots. I have followed the followong steps:

  1. Remove Plots
  2. Clean my compiled folder ny removing GR and GR_jll folders
  3. Install Plots again

This solved the issue for me.

@HelloHelpp Is your problem solved?