Cygwin not displaying graphic characters correctly

This post will have a very small audience, but that audience will be very interested :slight_smile:

So i upgraded my cygwin and it broke character display in the julia repl. What was particularly annoying is that the dataframe print outs were now a collection of garbage.

A kind soul on the cygwin mailing list suggested downgrading the “cygwin” package, it’s a package accessible from the main installer in the base category, to version 3.07.

Problem solved.

edit: i should add that this fixes the character display in mintty AND the x-window terminals.

Unfortunately I was forced to upgrade cygwin and now terminal display of characters is broken again. here for example is my attempt to display ‘pi’.

julia> 'π'
'π': Unicode U+03C0 (category Ll: Letter, lowercase)

it appears correctly in the julia shell of course. I was hoping that maybe someone else had run across this and could suggest some things to try.

I’ve tried a great many things, including changing character encoding and fonts and have not had any luck.

Any ideas ?