Correct way to plot in Juno pane

I can’t get the plot pane to work in Juno/Atom. gr(); plot(...) just opens a separate window. I came across a topic which said you have to use plotlyjs, so I installed it, but when I run plotlyjs() I get the following error:

ERROR: InitError: SystemError: opening file "C:\\Users\\sulli\\.julia\\packages\\PlotlyJS\\m2Lzd\\deps\\build.log": No such file or directory
 [1] systemerror(::String, ::Int32; extrainfo::Nothing) at .\error.jl:168
 [2] #systemerror#48 at .\error.jl:167 [inlined]
 [3] systemerror at .\error.jl:167 [inlined]
 [4] open(::String; lock::Bool, read::Nothing, write::Nothing, create::Nothing, truncate::Nothing, append::Nothing) at .\iostream.jl:284
 [5] open at .\iostream.jl:273 [inlined]
 [6] open(::Base.var"#296#297"{String}, ::String; kwargs::Base.Iterators.Pairs{Union{},Union{},Tuple{},NamedTuple{(),Tuple{}}}) at .\io.jl:323
 [7] open at .\io.jl:323 [inlined]
 [8] read at .\io.jl:410 [inlined]
 [9] __init__() at C:\Users\sulli\.julia\packages\PlotlyJS\m2Lzd\src\PlotlyJS.jl:65
 [10] _include_from_serialized(::String, ::Array{Any,1}) at .\loading.jl:697
 [11] _require_from_serialized(::String) at .\loading.jl:749
 [12] _require(::Base.PkgId) at .\loading.jl:1040
 [13] require(::Base.PkgId) at .\loading.jl:928
 [14] require(::Module, ::Symbol) at .\loading.jl:923
 [15] top-level scope at C:\Users\sulli\.julia\packages\Plots\vsE7b\src\backends.jl:489       
 [16] eval at .\boot.jl:331 [inlined]
 [17] _initialize_backend(::Plots.PlotlyJSBackend) at C:\Users\sulli\.julia\packages\Plots\vsE7b\src\backends.jl:488
 [18] backend at C:\Users\sulli\.julia\packages\Plots\vsE7b\src\backends.jl:174 [inlined]     
 [19] plotlyjs(; kw::Base.Iterators.Pairs{Union{},Union{},Tuple{},NamedTuple{(),Tuple{}}}) at 
 [20] plotlyjs() at C:\Users\sulli\.julia\packages\Plots\vsE7b\src\backends.jl:31
 [21] top-level scope at REPL[18]:1
during initialization of module PlotlyJS

I came across various topics on Discourse about how the plots pane doesn’t work anymore. I also saw something about this being a WebIO issue. I don’t know if those things are related.

The plots pane is expected to work - do you have it enabled in the julia-client settings?

Other than that it’s hard to say what’s happening without more info - are you on the latest version of all relevant Julia and Atom packages?


Yes, I have the plots pane enabled.

Juno: 0.12.6
Julia: 1.5.3
Atom: 1.53.0
Electron: 6.1.12
Plots 1.9.1
Atom (Julia package): 0.12.27
IJulia: 1.23.0
JLD: 0.10.0
Juno (Julia package): 0.8.4
PlotlyJS: 0.14.0

I put all the packages I think are relevant. Also, I’m on Windows 10 if that is relevant.

By Juno I presume you mean julia-client? What about ink (Atom package)? And what is Electron?

Other than that I don’t see any obvious issue - I am running the exact same versions of everything you’ve got, also on Win10, and am seeing this:

I was attempting to plot from the REPL. After seeing your code I thought to try running a file instead. Voila plots window magically starts working. Oddly, the REPL now plots to the pane as well, so first ctrl+enter running a Julia file jiggered some config file somewhere. Thank you for your insights.

BTW I think Juno is the official name for julia-client + Atom editor. See Electron is the JS browser engine that Atom is built on.