Can't install juno in Atom

I’ve tried installing Juno in atom but it always fails when installing ink. I have tried installing it separately and using apm install ink, but it gave me the following error log :

0 info it worked if it ends with ok
1 verbose cli [ 'C:\\Users\\tombe\\AppData\\Local\\atom\\app-1.49.0\\resources\\app\\apm\\bin\\node.exe',
1 verbose cli   'C:\\Users\\tombe\\AppData\\Local\\atom\\app-1.49.0\\resources\\app\\apm\\node_modules\\npm\\bin\\npm-cli.js',
1 verbose cli   '--globalconfig',
1 verbose cli   'C:\\Users\\tombe\\.atom\\.apm\\.apmrc',
1 verbose cli   '--userconfig',
1 verbose cli   'C:\\Users\\tombe\\.atom\\.apmrc',
1 verbose cli   'install',
1 verbose cli   'https://www.atom.io/api/packages/ink/versions/0.12.4/tarball',
1 verbose cli   '--target=5.0.13',
1 verbose cli   '--disturl=https://atom.io/download/electron',
1 verbose cli   '--arch=x64',
1 verbose cli   '--global-style' ]
2 info using npm@6.14.5
3 info using node@v10.20.1
4 verbose npm-session 1302de799b692d1f
5 silly install loadCurrentTree
6 silly install readLocalPackageData
7 http fetch GET 304 https://codeload.github.com/JunoLab/atom-ink/legacy.tar.gz/v0.12.4 1947ms (from cache)
8 silly pacote remote manifest for undefined@https://www.atom.io/api/packages/ink/versions/0.12.4/tarball fetched in 1992ms
9 timing stage:loadCurrentTree Completed in 2037ms
10 silly install loadIdealTree
11 silly install cloneCurrentTreeToIdealTree
12 timing stage:loadIdealTree:cloneCurrentTree Completed in 0ms
13 silly install loadShrinkwrap
14 timing stage:loadIdealTree:loadShrinkwrap Completed in 1ms
15 silly install loadAllDepsIntoIdealTree
16 silly resolveWithNewModule ink@0.12.4 checking installable status
17 http fetch GET 200 https://registry.npmjs.org/element-resize-detector 74ms (from cache)
18 silly pacote range manifest for element-resize-detector@^1.1.13 fetched in 78ms
19 silly resolveWithNewModule element-resize-detector@1.2.1 checking installable status
20 http fetch GET 304 https://registry.npmjs.org/katex 555ms (from cache)
21 http fetch GET 304 https://registry.npmjs.org/chroma-js 582ms (from cache)
22 silly pacote version manifest for katex@0.11.0 fetched in 569ms
23 silly resolveWithNewModule katex@0.11.0 checking installable status
24 http fetch GET 304 https://registry.npmjs.org/ansi_up 591ms (from cache)
25 silly pacote range manifest for chroma-js@^1.3.7 fetched in 609ms
26 silly resolveWithNewModule chroma-js@1.4.1 checking installable status
27 silly pacote range manifest for ansi_up@^3.0.0 fetched in 616ms
28 silly resolveWithNewModule ansi_up@3.0.0 checking installable status
29 http fetch GET 304 https://registry.npmjs.org/etch 622ms (from cache)
30 http fetch GET 304 https://registry.npmjs.org/fuzzaldrin-plus 616ms (from cache)
31 http fetch GET 304 https://registry.npmjs.org/fs-extra 628ms (from cache)
32 http fetch GET 304 https://registry.npmjs.org/underscore-plus 619ms (from cache)
33 silly pacote range manifest for etch@^0.14 fetched in 642ms
34 silly resolveWithNewModule etch@0.14.0 checking installable status
35 silly pacote range manifest for fuzzaldrin-plus@^0.1.0 fetched in 639ms
36 silly resolveWithNewModule fuzzaldrin-plus@0.1.0 checking installable status
37 http fetch GET 304 https://registry.npmjs.org/replace-in-file 630ms (from cache)
38 silly pacote range manifest for fs-extra@^5.0.0 fetched in 650ms
39 silly resolveWithNewModule fs-extra@5.0.0 checking installable status
40 http fetch GET 304 https://registry.npmjs.org/marked 638ms (from cache)
41 silly pacote range manifest for underscore-plus@^1.6.6 fetched in 640ms
42 silly resolveWithNewModule underscore-plus@1.7.0 checking installable status
43 silly pacote range manifest for replace-in-file@^3.0.0 fetched in 645ms
44 silly resolveWithNewModule replace-in-file@3.4.4 checking installable status
45 silly pacote range manifest for marked@^0.8.2 fetched in 650ms
46 silly resolveWithNewModule marked@0.8.2 checking installable status
47 http fetch GET 304 https://registry.npmjs.org/xterm 613ms (from cache)
48 silly pacote version manifest for xterm@4.6.0 fetched in 643ms
49 silly resolveWithNewModule xterm@4.6.0 checking installable status
50 http fetch GET 304 https://registry.npmjs.org/xterm-addon-unicode11 202ms (from cache)
51 silly pacote range manifest for xterm-addon-unicode11@^0.2.0 fetched in 208ms
52 silly resolveWithNewModule xterm-addon-unicode11@0.2.0 checking installable status
53 http fetch GET 304 https://registry.npmjs.org/xterm-addon-search 215ms (from cache)
54 http fetch GET 304 https://registry.npmjs.org/xterm-addon-fit 243ms (from cache)
55 silly pacote range manifest for xterm-addon-search@^0.7.0 fetched in 223ms
56 silly resolveWithNewModule xterm-addon-search@0.7.0 checking installable status
57 silly pacote range manifest for xterm-addon-fit@^0.4.0 fetched in 249ms
58 silly resolveWithNewModule xterm-addon-fit@0.4.0 checking installable status
59 http fetch GET 304 https://registry.npmjs.org/xterm-addon-web-links 193ms (from cache)
60 silly pacote range manifest for xterm-addon-web-links@^0.4.0 fetched in 197ms
61 silly resolveWithNewModule xterm-addon-web-links@0.4.0 checking installable status
62 http fetch GET 304 https://registry.npmjs.org/xterm-addon-webgl 192ms (from cache)
63 silly pacote range manifest for xterm-addon-webgl@^0.7.0 fetched in 198ms
64 silly resolveWithNewModule xterm-addon-webgl@0.7.0 checking installable status
65 http fetch GET 304 https://registry.npmjs.org/batch-processor 141ms (from cache)
66 silly pacote version manifest for batch-processor@1.0.0 fetched in 145ms
67 silly resolveWithNewModule batch-processor@1.0.0 checking installable status
68 http fetch GET 304 https://registry.npmjs.org/jsonfile 214ms (from cache)
69 silly pacote range manifest for jsonfile@^4.0.0 fetched in 221ms
70 silly resolveWithNewModule jsonfile@4.0.0 checking installable status
71 http fetch GET 304 https://registry.npmjs.org/universalify 223ms (from cache)
72 http fetch GET 304 https://registry.npmjs.org/graceful-fs 228ms (from cache)
73 silly pacote range manifest for universalify@^0.1.0 fetched in 231ms
74 silly resolveWithNewModule universalify@0.1.2 checking installable status
75 silly pacote range manifest for graceful-fs@^4.1.2 fetched in 236ms
76 silly resolveWithNewModule graceful-fs@4.2.4 checking installable status
77 http fetch GET 304 https://registry.npmjs.org/commander 164ms (from cache)
78 silly pacote range manifest for commander@^2.19.0 fetched in 172ms
79 silly resolveWithNewModule commander@2.20.3 checking installable status
80 http fetch GET 304 https://registry.npmjs.org/glob 273ms (from cache)
81 http fetch GET 304 https://registry.npmjs.org/chalk 278ms (from cache)
82 silly pacote range manifest for glob@^7.1.3 fetched in 284ms
83 silly resolveWithNewModule glob@7.1.6 checking installable status
84 silly pacote range manifest for chalk@^2.4.2 fetched in 286ms
85 silly resolveWithNewModule chalk@2.4.2 checking installable status
86 http fetch GET 304 https://registry.npmjs.org/yargs 286ms (from cache)
87 silly fetchPackageMetaData error for yargs@^13.2.2 Unexpected end of JSON input while parsing near '..."^10.0.0","rimraf":"^'
88 timing stage:rollbackFailedOptional Completed in 1ms
89 timing stage:runTopLevelLifecycles Completed in 3784ms
90 silly saveTree apm-install-dir-2020628-8492-s7fz1n.gjg6e
90 silly saveTree `-- ink@0.12.4
90 silly saveTree   +-- ansi_up@3.0.0
90 silly saveTree   +-- chroma-js@1.4.1
90 silly saveTree   +-- element-resize-detector@1.2.1
90 silly saveTree   | `-- batch-processor@1.0.0
90 silly saveTree   +-- etch@0.14.0
90 silly saveTree   +-- fs-extra@5.0.0
90 silly saveTree   | +-- graceful-fs@4.2.4
90 silly saveTree   | +-- jsonfile@4.0.0
90 silly saveTree   | `-- universalify@0.1.2
90 silly saveTree   +-- fuzzaldrin-plus@0.1.0
90 silly saveTree   +-- katex@0.11.0
90 silly saveTree   | `-- commander@2.20.3
90 silly saveTree   +-- marked@0.8.2
90 silly saveTree   +-- replace-in-file@3.4.4
90 silly saveTree   | +-- chalk@2.4.2
90 silly saveTree   | `-- glob@7.1.6
90 silly saveTree   +-- underscore-plus@1.7.0
90 silly saveTree   +-- xterm-addon-fit@0.4.0
90 silly saveTree   +-- xterm-addon-search@0.7.0
90 silly saveTree   +-- xterm-addon-unicode11@0.2.0
90 silly saveTree   +-- xterm-addon-web-links@0.4.0
90 silly saveTree   +-- xterm-addon-webgl@0.7.0
90 silly saveTree   `-- xterm@4.6.0
91 verbose stack SyntaxError: Unexpected end of JSON input while parsing near '..."^10.0.0","rimraf":"^'
91 verbose stack     at JSON.parse (<anonymous>)
91 verbose stack     at parseJson (C:\Users\tombe\AppData\Local\atom\app-1.49.0\resources\app\apm\node_modules\npm\node_modules\json-parse-better-errors\index.js:7:17)
91 verbose stack     at consumeBody.call.then.buffer (C:\Users\tombe\AppData\Local\atom\app-1.49.0\resources\app\apm\node_modules\npm\node_modules\node-fetch-npm\src\body.js:96:50)
91 verbose stack     at process._tickCallback (internal/process/next_tick.js:68:7)
92 verbose cwd C:\Users\tombe\AppData\Local\Temp\apm-install-dir-2020628-8492-s7fz1n.gjg6e
93 verbose Windows_NT 10.0.18363
94 verbose argv "C:\\Users\\tombe\\AppData\\Local\\atom\\app-1.49.0\\resources\\app\\apm\\bin\\node.exe" "C:\\Users\\tombe\\AppData\\Local\\atom\\app-1.49.0\\resources\\app\\apm\\node_modules\\npm\\bin\\npm-cli.js" "--globalconfig" "C:\\Users\\tombe\\.atom\\.apm\\.apmrc" "--userconfig" "C:\\Users\\tombe\\.atom\\.apmrc" "install" "https://www.atom.io/api/packages/ink/versions/0.12.4/tarball" "--target=5.0.13" "--disturl=https://atom.io/download/electron" "--arch=x64" "--global-style"
95 verbose node v10.20.1
96 verbose npm  v6.14.5
97 error Unexpected end of JSON input while parsing near '..."^10.0.0","rimraf":"^'
98 verbose exit [ 1, true ]

Hello! What version of Julia do you have installed? And the operational system?

1 Like

I’m using windows 10 and I have installed the version 1.4.2 of julia straight from julialang.org/downloads

I see. Have you tried installing JuliaPro? I think it is a better option for using Atom and Juno.

Here you can download it!

I’ll try that, thank you. I noticed in the quick start guide that it installs a copy of Atom with added stuff, is this a problem if I already have Atom installed ?

You can install it that way, no problem if you already have atom installed. :slight_smile:

Everything works now, thanks you ^^

1 Like