Very strange problems installing on win10

sigh
never had a problem before.
i’m trying to install on my work PC and getting very erratic behavior.

i have tried several times with both 1.6.5 and 1.7.2 and either
1 the executable is not present. that’s right everything else appears to be there but no executable
2 OR it installs, there is an executable, and the first time i try to install a package, the REPL quits and then the executable can no longer be found

i strongly suspect “windows security” is doing something. However, i have installed both python and librecad without issue, so this doesn’t seem to be a a virus detector deciding the program should be deleted or some other craziness.

any ideas ?

Thank you !

I am finding GitHub - JuliaLang/juliaup: Julia installer and version multiplexer to be very stable now. Give it a shot, but uninstall all existing julia first. Maybe the windows store integration treats security differently?

thx, i didn’t know about that.

i’m not using the windows store, i’m downloading the windows installer.

windows is so annoying. this is the first time i’ve had any trouble at all across multiple PCs running win10. i’m very suspicious that it’s company security software of some sort causing the problem. the weirdness is that it only appears to be causing a problem for julia.

Try juliaup, which will likely become the “official” installation method at some point. Couldn’t be easier to use. After uninstalling other julia stuff, run

winget install julia -s msstore

See GitHub - JuliaLang/juliaup: Julia installer and version multiplexer for more.

Thanks for the links, I tried it and see the same behavior.

This sounds like an antivirus in action - check your quarantined files. Cisco AMP Endpoint Connector has been brought up as a source of this a few times (and I’ve experienced this myself), but I’m sure there’s other similar products as well.

1 Like

grrrr.

That’s the problem.

apparently “AMP endpoint connector” has been renamed to “cisco secure endpoint”.

cisco software causing problems. shocking.

opened up the quarantine and there was the julia executable.

guess i’ll go contact IT and see if there’s anything that can be done.

Thank you !

edit: i guess i should ask if there’s any chance this is a real problem ? lol

Yeah, it is a real problem with your antivirus :slight_smile:

1 Like

:rofl:

Yes the solution is to whitelist julia.exe which will have to be done by your company IT admin. Annoyingly in my experience this will have to happen for each new release, i.e. 1.8 will have to be whitelisted separately from 1.7.2 etc.