Build error Pkg.add("CoinOptServices")


#1

Hi, i’m a studet of mathmatich from Pisa, i’m using Julia and JuMP for my thesis, i have this error when i try to install ConOptServices on Julia with the funtion Pkg.add(“CoinOptServices”):
================================[ BUILD ERRORS ]================================

WARNING: CoinOptServices had build errors.

  • packages with build errors remain installed in /root/.julia/v0.5
  • build the package(s) and all dependencies with Pkg.build("CoinOptServices")
  • build a single package by running its deps/build.jl script

================================================================================
can you halp me?
Thnaks

Matteo Cacciola


#2

I’d suggest browsing the Github CoinOptServices repo to see if there are any requirements that you’re not meeting. Otherwise, you’d need to report the details of your Julia installation and the messages that you get when running Pkg.build("CoinOptServices"). Perhaps raising a new issue over there would be better anyway?

Fyi, on Julia v0.5 and macOS Sierra I added the package without any problems.


#3

This is the complete error message

checking if library version is set… 9:10:6
checking for pkg-config… no
checking for COIN-OR package CoinDepend… skipped check via pkg-config, redirect to fallback
checking for COIN-OR package CoinDepend (fallback)… no, dependency coinutils not available
configure: error: Required package CoinUtils or Osi not available.
configure: error: /bin/bash ‘…/…/SYMPHONY/configure’ failed for SYMPHONY
===========================[ ERROR: CoinOptServices ]===========================

LoadError: failed process: Process(setenv(../configure --prefix=/home/cacciola/.julia/v0.5/CoinOptServices/deps/usr --enable-dependency-linking coin_skip_warn_cflags=yes coin_skip_warn_cxxflags=yes coin_skip_warn_fflags=yes '--with-coinutils-lib=-L/home/cacciola/.julia/v0.5/Cbc/deps/usr/lib -lCoinUtils' --with-coinutils-incdir=/home/cacciola/.julia/v0.5/Cbc/deps/usr/lib/../include/coin '--with-osi-lib=-L/home/cacciola/.julia/v0.5/Cbc/deps/usr/lib -lOsi -lCoinUtils' --with-osi-incdir=/home/cacciola/.julia/v0.5/Cbc/deps/usr/lib/../include/coin '--with-clp-lib=-L/home/cacciola/.julia/v0.5/Cbc/deps/usr/lib -lClp -lOsiClp' --with-clp-incdir=/home/cacciola/.julia/v0.5/Cbc/deps/usr/lib/../include/coin '--with-cgl-lib=-L/home/cacciola/.julia/v0.5/Cbc/deps/usr/lib -lCgl' --with-cgl-incdir=/home/cacciola/.julia/v0.5/Cbc/deps/usr/lib/../include/coin '--with-cbc-lib=-L/home/cacciola/.julia/v0.5/Cbc/deps/usr/lib -lCbc' --with-cbc-incdir=/home/cacciola/.julia/v0.5/Cbc/deps/usr/lib/../include/coin '--with-blas=-L/home/cacciola/.julia/v0.5/Ipopt/deps/usr/lib -lcoinblas' '--with-lapack=-L/home/cacciola/.julia/v0.5/Ipopt/deps/usr/lib -lcoinlapack' '--with-mumps-lib=-L/home/cacciola/.julia/v0.5/Ipopt/deps/usr/lib -lcoinmumps' '--with-ipopt-lib=-L/home/cacciola/.julia/v0.5/Ipopt/deps/usr/lib -lipopt',String[“PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games”,“PWD=/home/cacciola”,“SHELL=/bin/sh”,“SSH_CONNECTION=93.32.74.180 62068 10.0.0.8 22”,“OPENBLAS_NUM_THREADS=8”,“MAIL=/var/mail/cacciola”,“LANG=it_IT.UTF-8”,“LOGNAME=cacciola”,“XDG_RUNTIME_DIR=/run/user/1006”,“XDG_SESSION_ID=662”,“PKG_CONFIG_PATH=/home/cacciola/.julia/v0.5/Cbc/deps/usr/lib/pkgconfig:/home/cacciola/.julia/v0.5/Ipopt/deps/usr/lib/pkgconfig”,“SSH_CLIENT=93.32.74.180 62068 22”,“USER=cacciola”,“SSH_TTY=/dev/pts/1”,“HOME=/home/cacciola”,“TERM=xterm”,“OPENBLAS_MAIN_FREE=1”]), ProcessExited(1)) [1]
while loading /home/cacciola/.julia/v0.5/CoinOptServices/deps/build.jl, in expression starting on line 69

================================================================================

================================[ BUILD ERRORS ]================================

WARNING: CoinOptServices had build errors.

  • packages with build errors remain installed in /home/cacciola/.julia/v0.5
  • build the package(s) and all dependencies with Pkg.build("CoinOptServices")
  • build a single package by running its deps/build.jl script

===============================================================================