Clp: problem to build the package

Dear all,

I have installed Clp, but when I try to build it, julia reports:

julia> Pkg.build(“Clp”)
Building CodecZlib ─→ ~/.julia/packages/CodecZlib/5t9zO/deps/build.log
Building MbedTLS ───→ ~/.julia/packages/MbedTLS/X4xar/deps/build.log
Building ZipFile ───→ ~/.julia/packages/ZipFile/DW0Qr/deps/build.log
Building CodecBzip2 → ~/.julia/packages/CodecBzip2/T5yr7/deps/build.log
Building Clp ───────→ ~/.julia/packages/Clp/3ZgbR/deps/build.log
┌ Error: Error building Clp:
│ [ Info: Downloading https://github.com/JuliaBinaryWrappers/CoinUtils_jll.jl/releases/download/CoinUtils-v2.11.3+2/CoinUtils.v2.11.3.x86_64-apple-darwin14-cxx03.tar.gz to /Users/luca/.julia/packages/Clp/3ZgbR/deps/usr/downloads/CoinUtils.v2.11.3.x86_64-apple-darwin14-cxx03.tar.gz…
│ ERROR: LoadError: LoadError: Could not download https://github.com/JuliaBinaryWrappers/CoinUtils_jll.jl/releases/download/CoinUtils-v2.11.3+2/CoinUtils.v2.11.3.x86_64-apple-darwin14-cxx03.tar.gz to /Users/luca/.julia/packages/Clp/3ZgbR/deps/usr/downloads/CoinUtils.v2.11.3.x86_64-apple-darwin14-cxx03.tar.gz:
│ ErrorException("")
│ Stacktrace:
│ [1] error(::String) at ./error.jl:33
│ [2] #download#96(::Bool, ::Function, ::String, ::String) at /Users/luca/.julia/packages/BinaryProvider/U2dKK/src/PlatformEngines.jl:619
│ [3] #download at ./none:0 [inlined]
│ [4] #download_verify#97(::Bool, ::Bool, ::Bool, ::Function, ::String, ::String, ::String) at /Users/luca/.julia/packages/BinaryProvider/U2dKK/src/PlatformEngines.jl:688
│ [5] #download_verify at ./none:0 [inlined]
│ [6] #install#137(::Prefix, ::String, ::Bool, ::Bool, ::Bool, ::Function, ::String, ::String) at /Users/luca/.julia/packages/BinaryProvider/U2dKK/src/Prefix.jl:314
│ [7] (::getfield(BinaryProvider, Symbol("#kw##install")))(::NamedTuple{(:prefix, :force, :verbose),Tuple{Prefix,Bool,Bool}}, ::typeof(install), ::String, ::String) at ./none:0
│ [8] top-level scope at /Users/luca/.julia/packages/Clp/3ZgbR/deps/build_CoinUtils.v2.11.3.jl:55
│ [9] include at ./boot.jl:317 [inlined]
│ [10] include_relative(::Module, ::String) at ./loading.jl:1044
│ [11] include at ./sysimg.jl:29 [inlined]
│ [12] include(::String) at ./loading.jl:1079
│ [13] top-level scope at none:0
│ [14] eval at ./boot.jl:319 [inlined]
│ [15] evalfile(::String, ::Array{String,1}) at ./loading.jl:1075 (repeats 2 times)
│ [16] top-level scope at /Users/luca/.julia/packages/Clp/3ZgbR/deps/build.jl:137
│ [17] include at ./boot.jl:317 [inlined]
│ [18] include_relative(::Module, ::String) at ./loading.jl:1044
│ [19] include(::Module, ::String) at ./sysimg.jl:29
│ [20] include(::String) at ./client.jl:392
│ [21] top-level scope at none:0
│ in expression starting at /Users/luca/.julia/packages/Clp/3ZgbR/deps/build_CoinUtils.v2.11.3.jl:53
│ in expression starting at /Users/luca/.julia/packages/Clp/3ZgbR/deps/build.jl:117
│ [19:38:07] curl: (48) An unknown option was passed in to libcurl
└ @ Pkg.Operations /Users/julia/buildbot/worker/package_macos64/build/usr/share/julia/stdlib/v1.0/Pkg/src/Operations.jl:1096

Try again. This is probably just be a network connectivity issue.

Alternatively, if you are on a company network, your firewall may be blocking things. Contact your IT support.

1 Like