Avast AntiVirus stole my Julia 1.0.2 executable! Windows 7 pro antivirus problems

bug

#1

Hello, I’m running Windows 7 pro, old Intel i7 processor and Julia 1.0.2.

I was working late last night on on some documentation for a Julia package. I wanted to run make.jl locally so I tried to add Documenter in pkg mode. I kept getting annoying Avast virus warnings no matter how many times I clicked ‘create exception’ for julia.exe.

Eventually I just disabled my all Avast features for 10 minutes, downloaded Documenter.jl and then re-enabled Avast. Seemed to work fine and I carried on using Julia as expected and shut down my computer when finished.

This morning I have tried to load julia from cmd window but it says

'julia' is not recognized as an internal or external command, operable program or batch file.

Even though it’s definitely on my path. I looked in the folder and sure enough, julia.exe is gone!

I definitely didn’t delete it so the most likely explanation seems to be Avast. I’m looking into it now but was wondering if anyone else has had this or similar issues and how to work around them?

update: It’s not in my ‘virus chest’… Hmm avast seems to be getting worse these days. Maybe I should just get a different antivirus. As a temporary fix I’ve just reinstalled Julia 1.0.2


#2

I’m using Avira instead and I’ve added the whole folders Julia and VS Code to exceptions and added the processes to the firewall exclusions, and it seems to work.

Maybe you have additional security features you need to disable on Avast.