Autocompletion & tab complete no longer work after Atom Package update


#1

Today Atom told me there where updates available to 3 packages, Julia_client, ink, and one other. I promply updated and after the restart Autocompletion is no longer working. If I hit tab where I previously got completion I now get spaces.

Working on OSX.


#2

See here – you’ll also need to update your Julia packages.


#3

@pfitzseb
I uninstalled and reinstalled , Julia_client, language_julia, ink, and tool_bar. I am still having the same issue. Is the next step a total Atom reinstall?


#4

I believe he meant doing ] up in Julia.


#5

I have done that as well.


#6

Had a similar problem. Mine was fixed by exiting, typing apm uninstall latex-completions and then apm install latex-completions


#7

@jarrison
You hit the nail on the head thank you.


#8

I thought I had things fixed but I am still having issues with the latest Juno build. Auto complete is just not working correctly. It seems like the problem is that the filtering of that autocomplete options is failing to do so, best illistrated by the photo below. I am trying to use DataFrame, and you can see the pattern is matching, but the filtering isn’t happening.

Now thinking it might be just the Julia code portion it appears that the Latex expansion isn’t matching either:

Does anyone have anythoughs on how to fix this?


#9

Before the previous post I had done a clean install of atom and Juno. The post was a reflection of having the same problem. I have just uninstalled and reinstalled latex-completion, and both cases are again working.

This is strange, does anyone have an idea what could cause the latex-completion fix to work for a while, then suddenly stop?


#10

I have traced the issue to a directory specific problem. Will be submitting an issue on github.