Warning: Terminal not fully functional

Hi everyone,

I am new to the Discourse and hopefully posted this correctly. I have been dealing with this warning on and off for years while using Juno:

┌ Warning: Terminal not fully functional
└ @ Base client.jl:353

I usually delete my .atom folder when it happens, reinstall Juno, and live without the problem for a few weeks. Lately, it comes back after I restart Atom. Its surprising no one else seems to have this problem, since I deal with it all the time. I am using fedora, and everything is up to date.

Any ideas would be much appreciated - thanks.

1 Like

I had the same problem back when I was using fedora. For me, it appeared less if I launched atom by typing atom in the terminal rather than launching it from the launcher

Thanks- that does work! I feel like I should be looking for a permanent fix, but instead I am going to get back to working and feeling less frustrated about it…

What’s the output for ENV["TERM"] in Juno’s Julia REPL for you?

When I start it from the terminal and things are working properly, I get: “xterm-256color”.
When it is not fully functional, I get “dumb”.

I have the same problem on Oracle Enterprise Linux 7.

It’ s happening almost all the times now except on the first run (when juno installs the atom package).

It’s not just the error message. It is actually not fully functional:

  • does not enter package/help mode when pressing ]/?
  • workspace pane does not show variables from console session.

After Juno install, it is actually working. It stops working after Atom is restarted.

I will try to add export TERM=xterm-256color to my atom run script.

I can confirm adding:

 export TERM=xterm-256color 

to my atom startup script works.
Just make sure that the desktop file specifies to run the startup script not directly the binary.

Ok, this is very weird – Juno is very specifically setting $TERM = xterm-256color before starting a REPL. This commit might or might not improve the situation, we’ll see.