VS Code Julia version configuration issue

I have Julia 1.4.1 and 1.5.0 beta installed.

paul@extra:~/apps$ dir
julia-1.4.1  julia-1.5.0-beta1

1.5 beta is on my path:

paul@extra:~$ echo $PATH

and works fine from terminal. VS Code was using Julia 1.4 as it was the first one installed, but I wanted to switch to 1.5.0. I changed settings to:

    "julia.enableTelemetry": true,
    "python.pythonPath": "/usr/bin/python3",
    "editor.minimap.enabled": false,
    "breadcrumbs.enabled": false,
    "explorer.confirmDelete": false,
    "julia.executablePath": "/home/paul/apps/julia-1.5.0-beta1/bin",
    "julia.enableCrashReporter": false

and language server couldn’t start. I tried:

    "julia.executablePath": "/home/paul/apps/julia-1.4.1/bin",

with the same result. I tried a few shorter or longer path versions, restarting VS Code after each change and no cigar. I removed julia.executablePath parameter and automagically my Julia version in VS Code is 1.5.0-beta1` now. How did that happen?

Perhaps, it has something to do with only one /home/paul/.julia directory used by both versions?

maybe could you try: "julia.executablePath": "/home/paul/apps/julia-1.5.0-beta1/bin/julia"

1 Like

I tried that.


Apparently, I didn’t try hard enough. This time, one of these does switch the version:

"julia.executablePath": "/home/paul/apps/julia-1.5.0-beta1/bin/julia"
"julia.executablePath": "/home/paul/apps/julia-1.4.1/bin/julia"

I made a pull request to clarify the documentation.