VS Code extension v0.11 released

announcement

#21

To answer my own question:

Adding the following code to the file startup.jl in ~/.julia/config makes it possible to plot in a separate window with PyPlot from the build-in repl:

atreplinit() do REPL
    @async begin
        sleep(0.1)
        try
            @eval Base.Multimedia.popdisplay()
        catch err
            warn("Could not pop the multimedia display.")
        end
    end
end

Thanks!


#22

We should probably make that easier, and add say enableplotpane and disableplotpane or something like that… https://github.com/JuliaEditorSupport/julia-vscode/issues/655


#23

I’ve be been an atom user for a while now but want to try vscode. (Primarily because if the excellent latex-Workshop.)

At first glance I am missing In vscode-Code Julia the possibility to evaluate into a module. My understanding is that it always evaluated into the REPL? Is the wirkflow then simply based inn Revise?


#24

We did have an option to eval into a module at some point. I think that should still work? There should be a command to change the module of the REPL, I think…


#25

Eval-in-module was removed in favour of using Revise for the last release. Given time constraints it seems sensible to use a well engineered and maintained package than our own (rather hacky) approach (though the two approaches may not provide exactly the same functionality).


#26

My use case: Julia on WSL + VS Code on Windows
It seems julia.executablePath could not be set.
I was wondering if you provide additional way to point to the julia executable wsl julia.
Thanks!
p.s. my current workaround setting is as follows.

{
    "terminal.integrated.shell.windows": "C:\\Windows\\System32\\wsl.exe",
    "terminal.external.windowsExec": "C:\\Windows\\System32\\wsl.exe",
    "terminal.integrated.shellArgs.windows": ["julia"]
}

However I was wondering if julia.executable be provided beside julia.executablePath. That is, instead of specify the path is it possible to specify the command?


#27

I have only used Juno so far. Now, I downloaded VS Code + the Julia extension. It looks beautiful. Great work! I open a jl file, select the lines to be run and then press CTRL + Enter. As a result, the selected lines are copied to the REPL and after that they are executed. Is this the way the VS Code works or it is just a bug? Personally, I don’t find useful to have the code copied to the REPL. I think that would be a problem if the code is long. Is there any other way to run the jl file without the selected lines being copied to the REPL? I am thinking about something like the run file arrow of Juno.


#28

‘Execue File’ normally bound to F5, though if the file is dirty (has unsaved edits) it will still paste it to the REPL


#29

@ZacLN Thanks. Yes, that is was I found in many blogs. However, in the VS Code I have all F5 combinations go to the debug modes. Then, the command palette opens asking for “Select Environment.” I don’t understand how to follow from there.


#30

I can confirm this. Problems solved after running this procedure. Thanks Phelipe.


#31

Excellent work with v0.11!

Question: is it possible to enable Unicode character completion of LaTeX commands in markdown files? (It works in .jl files, just not in the .md context)

[This might be unrelated to the Julia extension, I’m not sure, but it would be great if it could be generalised a bit to help with markdown completion too]

EDIT: Nevermind, I just found out about the Unicode Latex extension (https://marketplace.visualstudio.com/items?itemName=oijaz.unicode-latex)


#32

I think our completion should work in *.jmd files!


#33

Thank you all for this.
For now it works fine


#34

I get “error server not running” and the linter doesn’t seem to work?

Do I need to install anything from the Julia side to get the extension to work?


#35

Can you start a REPL?


#36

yes