Update on julia-client 0.9.4 fails

I get the follwoing error message on a Windows 10 machine. Julia packages are up to date.

> @pfitzseb/node-pty-prebuilt@0.8.1-prebuilt3 install C:\Users\CHRIST~1\AppData\Local\Temp\apm-install-dir-119717-2192-1uotbmw.vgmx\node_modules\julia-client\node_modules\@pfitzseb\node-pty-prebuilt
> prebuild-install || node scripts/install.js

C:\Users\CHRIST~1\AppData\Local\Temp\apm-install-dir-119717-2192-1uotbmw.vgmx\node_modules\julia-client\node_modules\@pfitzseb\node-pty-prebuilt>if not defined npm_config_node_gyp (node "C:\Users\Christian\AppData\Local\atom\app-1.40.0\resources\app\apm\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild )  else (node "C:\Users\Christian\AppData\Local\atom\app-1.40.0\resources\app\apm\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js" rebuild ) 

prebuild-install WARN install No prebuilt binaries found (target=3.1.10 runtime=node arch=x64 libc= platform=win32)
gyp ERR! configure error 
gyp ERR! stack Error: Can't find Python executable "python", you can set the PYTHON env variable.
gyp ERR! stack     at PythonFinder.failNoPython (C:\Users\Christian\AppData\Local\atom\app-1.40.0\resources\app\apm\node_modules\npm\node_modules\node-gyp\lib\configure.js:492:19)
gyp ERR! stack     at PythonFinder.<anonymous> (C:\Users\Christian\AppData\Local\atom\app-1.40.0\resources\app\apm\node_modules\npm\node_modules\node-gyp\lib\configure.js:517:16)
gyp ERR! stack     at C:\Users\Christian\AppData\Local\atom\app-1.40.0\resources\app\apm\node_modules\npm\node_modules\graceful-fs\polyfills.js:284:29
gyp ERR! stack     at FSReqWrap.oncomplete (fs.js:182:21)
gyp ERR! System Windows_NT 10.0.18362
gyp ERR! command "C:\\Users\\Christian\\AppData\\Local\\atom\\app-1.40.0\\resources\\app\\apm\\bin\\node.exe" "C:\\Users\\Christian\\AppData\\Local\\atom\\app-1.40.0\\resources\\app\\apm\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild"
gyp ERR! cwd C:\Users\CHRIST~1\AppData\Local\Temp\apm-install-dir-119717-2192-1uotbmw.vgmx\node_modules\julia-client\node_modules\@pfitzseb\node-pty-prebuilt
gyp ERR! node -v v10.2.1
gyp ERR! node-gyp -v v3.7.0
gyp ERR! not ok 
npm WARN enoent ENOENT: no such file or directory, open 'C:\Users\CHRIST~1\AppData\Local\Temp\apm-install-dir-119717-2192-1uotbmw.vgmx\package.json'
npm WARN apm-install-dir-119717-2192-1uotbmw.vgmx No description
npm WARN apm-install-dir-119717-2192-1uotbmw.vgmx No repository field.
npm WARN apm-install-dir-119717-2192-1uotbmw.vgmx No README data
npm WARN apm-install-dir-119717-2192-1uotbmw.vgmx No license field.

npm ERR! errno 1
npm ERR! @pfitzseb/node-pty-prebuilt@0.8.1-prebuilt3 install: `prebuild-install || node scripts/install.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the @pfitzseb/node-pty-prebuilt@0.8.1-prebuilt3 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Christian\.atom\.apm\_logs\2019-08-17T13_20_00_393Z-debug.log

I already tried a clean reinstall but the problem persists. The Python executable is in the path. I do not understand what is meant by Can't find Python executable "python", you can set the PYTHON env variable.

Note that previous installations worked fine

I am tagging along, have the same problem.
Found this semi-old thread, but that can’t be a solution for good… : https://github.com/JunoLab/Juno.jl/issues/332

The fix is described in the JunoLab FAQ:


Juno doesn’t work properly after some Atom packages were updated. What do I do?

There’s a chance the update of julia-client failed. To get a clean re-install while preserving any setting you might have changed, try the following steps:

  1. Close all Atom instances.
  2. Start a terminal (e.g. cmd on Windows or the Terminal App on MacOS)
  3. Execute apm uninstall julia-client .
  4. Execute apm install julia-client .
  5. Start Juno. Evertyhing should work again.

However, apm install julia-client fails for me

The thread I linked above has a workaround (and the next Atom release will provide an actual fix):