Atom julia-client fails to install


#1

Hi,

I would love to try out the Julia language for some image registration problem that I have. In order to write Julia scripts I would like to use the Atom editor/IDE, however I am running into problems on my linux machine (tried it on my windows pc, everything works fine).

Some information about my setup
Kernel version:
#42~16.04.1-Ubuntu SMP Wed Mar 7 16:03:28 UTC 2018
Kernel release:
4.13.0-37-generic
64bit Zorin OS version on a Lenovo Thinkpad W540 with, Intel core i7, 8gb ram, nvidea quadro 1100km

I installed the latest Linux Julia distribution for 64 bit linux i.e. “Generic Linux Binaries for x86”

I then installed Atom from their website using the .deb package they provide.

Then within Atom, I tried to install the uber-juno package as described in the uber-juno git repository. When the uber-juno package triest to install the julia-client package I receive an error message.

The error that I recieve is the following:

node-pty-prebuilt@0.7.3 install /tmp/apm-install-dir-118311-27770-uvd3o9.fgwp8yf1or/node_modules/julia-client/node_modules/node-pty-prebuilt
prebuild-install || node scripts/install.js

/tmp/apm-install-dir-118311-27770-uvd3o9.fgwp8yf1or
└── (empty)

npm WARN deprecated coffee-script@1.12.7: CoffeeScript on NPM has moved to “coffeescript” (no hyphen)
prebuild-install info begin Prebuild-install version 2.5.1
prebuild-install info looking for local prebuild @ prebuilds/node-pty-prebuilt-v0.7.3-electron-v54-linux-x64.tar.gz
prebuild-install info looking for cached prebuild @ /home/niels/.atom/.apm/_prebuilds/https-github.com-daviwil-node-pty-prebuilt-releases-download-v0.7.3-node-pty-prebuilt-v0.7.3-electron-v54-linux-x64.tar.gz
prebuild-install http request GET https://github.com/daviwil/node-pty-prebuilt/releases/download/v0.7.3/node-pty-prebuilt-v0.7.3-electron-v54-linux-x64.tar.gz
prebuild-install http 200 https://github.com/daviwil/node-pty-prebuilt/releases/download/v0.7.3/node-pty-prebuilt-v0.7.3-electron-v54-linux-x64.tar.gz
prebuild-install info downloading to @ /home/niels/.atom/.apm/_prebuilds/https-github.com-daviwil-node-pty-prebuilt-releases-download-v0.7.3-node-pty-prebuilt-v0.7.3-electron-v54-linux-x64.tar.gz.27915-536d93bd3018e.tmp
prebuild-install WARN install ENAMETOOLONG: name too long, open ‘/home/niels/.atom/.apm/_prebuilds/https-github.com-daviwil-node-pty-prebuilt-releases-download-v0.7.3-node-pty-prebuilt-v0.7.3-electron-v54-linux-x64.tar.gz.27915-536d93bd3018e.tmp’
gyp ERR! configure error
gyp ERR! stack Error: Python executable “/usr/share/atom/resources/app/apm/bin/python-interceptor.sh” is v3.6.5, which is not supported by gyp.
gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.
gyp ERR! stack at failPythonVersion (/usr/share/atom/resources/app/apm/node_modules/node-gyp/lib/configure.js:454:14)
gyp ERR! stack at /usr/share/atom/resources/app/apm/node_modules/node-gyp/lib/configure.js:443:9
gyp ERR! stack at ChildProcess.exithandler (child_process.js:197:7)
gyp ERR! stack at emitTwo (events.js:106:13)
gyp ERR! stack at ChildProcess.emit (events.js:191:7)
gyp ERR! stack at maybeClose (internal/child_process.js:877:16)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)
gyp ERR! System Linux 4.13.0-37-generic
gyp ERR! command “/usr/share/atom/resources/app/apm/bin/node” “/usr/share/atom/resources/app/apm/node_modules/.bin/node-gyp” “rebuild”
gyp ERR! cwd /tmp/apm-install-dir-118311-27770-uvd3o9.fgwp8yf1or/node_modules/julia-client/node_modules/node-pty-prebuilt
gyp ERR! node -v v6.9.5
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok
npm WARN enoent ENOENT: no such file or directory, open ‘/tmp/apm-install-dir-118311-27770-uvd3o9.fgwp8yf1or/package.json’
npm WARN apm-install-dir-118311-27770-uvd3o9.fgwp8yf1or No description
npm WARN apm-install-dir-118311-27770-uvd3o9.fgwp8yf1or No repository field.
npm WARN apm-install-dir-118311-27770-uvd3o9.fgwp8yf1or No README data
npm WARN apm-install-dir-118311-27770-uvd3o9.fgwp8yf1or No license field.
npm ERR! Linux 4.13.0-37-generic
npm ERR! argv “/usr/share/atom/resources/app/apm/bin/node” > “/usr/share/atom/resources/app/apm/node_modules/npm/bin/npm-cli.js” “–globalconfig”
“/home/niels/.atom/.apm/.apmrc” “–userconfig” “/home/niels/.atom/.apmrc” “install” “/tmp/d-118311-27770-he1zdt.a5750qw7b9/package.tgz” “–runtime=electron” “–target=1.7.11” “–arch=x64” “–global-style”
npm ERR! node v6.9.5
npm ERR! npm v3.10.10
npm ERR! code ELIFECYCLE

npm ERR! node-pty-prebuilt@0.7.3 install: prebuild-install || node scripts/install.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the node-pty-prebuilt@0.7.3 install script ‘prebuild-install || node scripts/install.js’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the node-pty-prebuilt package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! prebuild-install || node scripts/install.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs node-pty-prebuilt
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls node-pty-prebuilt
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /tmp/apm-install-dir-118311-27770-uvd3o9.fgwp8yf1or/npm-debug.log
npm ERR! code 1

The error message above reports to supply the debug log created, however the temporary folder it refers to does not exist. I also read a note about updating npm and node.js, which I did. Then trying to either reinstall uber-juno, or trying to manually install julia-client as an Atom package, both result in the same error message. I also noted something about a python executable that needs a version >= v2.5.0 & < 3.0.0. However on my machine I have both python2.7 and python 3.6.5 installed. Perhaps something is going wrong here?
Both versions are on the path, with the anaconda version having higher priority than the one installed on my distro. Nevertheless python2 still works when calling python2.

lrwxrwxrwx 1 niels niels 9 Apr 10 23:04 /opt/anaconda3/bin/python3 -> python3.6
lrwxrwxrwx 1 niels niels 9 Apr 10 23:04 /opt/anaconda3/bin/python -> python3.6
lrwxrwxrwx 1 root root 9 Mar 30 23:25 /usr/bin/python2 -> python2.7
lrwxrwxrwx 1 root root 9 Mar 30 23:25 /usr/bin/python3 -> python3.5
lrwxrwxrwx 1 root root 9 Mar 30 23:25 /usr/bin/python -> python2.7

Thanks in advance,

Cheers,
Niels