Error installing atom-julia-client 0.6.12


#1

Hi,

I get the error below while trying to update atom-julia-client to version 0.6.12 using Atom 1.26.0, JuliaPro 0.6.2.1 and IntelPython 3.6.3.

Updating to “julia-client@0.6.12” failed.Hide output…

> node-pty-prebuilt@0.7.3 install C:\Users\marc\AppData\Local\Temp\apm-install-dir-118319-14980-1p4xjo3.wf2mqs38fr\node_modules\julia-client\node_modules\node-pty-prebuilt
> prebuild-install || node scripts/install.js


C:\Users\marc\AppData\Local\Temp\apm-install-dir-118319-14980-1p4xjo3.wf2mqs38fr\node_modules\julia-client\node_modules\node-pty-prebuilt>if not defined npm_config_node_gyp (node "C:\Users\marc\AppData\Local\atom\app-1.26.0\resources\app\apm\node_modules\npm\bin\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild )  else (node "C:\Users\marc\AppData\Local\atom\app-1.26.0\resources\app\apm\bin\\..\node_modules\node-gyp\bin\node-gyp.js" rebuild ) 
C:\Users\marc\AppData\Local\Temp\apm-install-dir-118319-14980-1p4xjo3.wf2mqs38fr
`-- (empty)


npm WARN deprecated coffee-script@1.12.7: CoffeeScript on NPM has moved to "coffeescript" (no hyphen)
prebuild-install WARN install unexpected end of file
gyp ERR! configure error 
gyp ERR! stack Error: Python executable "C:\IntelPython3\python.exe" is v3.6.3, which is not supported by gyp.
gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.
gyp ERR! stack     at failPythonVersion (C:\Users\marc\AppData\Local\atom\app-1.26.0\resources\app\apm\node_modules\node-gyp\lib\configure.js:454:14)
gyp ERR! stack     at C:\Users\marc\AppData\Local\atom\app-1.26.0\resources\app\apm\node_modules\node-gyp\lib\configure.js:443:9
gyp ERR! stack     at ChildProcess.exithandler (child_process.js:197:7)
gyp ERR! stack     at emitTwo (events.js:106:13)
gyp ERR! stack     at ChildProcess.emit (events.js:191:7)
gyp ERR! stack     at maybeClose (internal/child_process.js:877:16)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)
gyp ERR! System Windows_NT 10.0.16299
gyp ERR! command "C:\\Users\\marc\\AppData\\Local\\atom\\app-1.26.0\\resources\\app\\apm\\bin\\node.exe" "C:\\Users\\marc\\AppData\\Local\\atom\\app-1.26.0\\resources\\app\\apm\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild"
gyp ERR! cwd C:\Users\marc\AppData\Local\Temp\apm-install-dir-118319-14980-1p4xjo3.wf2mqs38fr\node_modules\julia-client\node_modules\node-pty-prebuilt
gyp ERR! node -v v6.9.5
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok 
npm WARN enoent ENOENT: no such file or directory, open 'C:\Users\marc\AppData\Local\Temp\apm-install-dir-118319-14980-1p4xjo3.wf2mqs38fr\package.json'
npm WARN apm-install-dir-118319-14980-1p4xjo3.wf2mqs38fr No description
npm WARN apm-install-dir-118319-14980-1p4xjo3.wf2mqs38fr No repository field.
npm WARN apm-install-dir-118319-14980-1p4xjo3.wf2mqs38fr No README data
npm WARN apm-install-dir-118319-14980-1p4xjo3.wf2mqs38fr No license field.
npm ERR! Windows_NT 10.0.16299
npm ERR! argv "C:\\Users\\marc\\AppData\\Local\\atom\\app-1.26.0\\resources\\app\\apm\\bin\\node.exe" "C:\\Users\\marc\\AppData\\Local\\atom\\app-1.26.0\\resources\\app\\apm\\node_modules\\npm\\bin\\npm-cli.js" "--globalconfig" "C:\\Users\\marc\\.atom\\.apm\\.apmrc" "--userconfig" "C:\\Users\\marc\\.atom\\.apmrc" "install" "C:\\Users\\marc\\AppData\\Local\\Temp\\d-118319-14980-1euq7pp.nncqujif6r\\package.tgz" "--runtime=electron" "--target=1.7.11" "--arch=x64" "--global-style" "--msvs_version=2015"
npm ERR! node v6.9.5
npm ERR! npm  v3.10.10
npm ERR! code ELIFECYCLE

npm ERR! node-pty-prebuilt@0.7.3 install: `prebuild-install || node scripts/install.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the node-pty-prebuilt@0.7.3 install script 'prebuild-install || node scripts/install.js'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the node-pty-prebuilt package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     prebuild-install || node scripts/install.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs node-pty-prebuilt
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls node-pty-prebuilt
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     C:\Users\marc\AppData\Local\Temp\apm-install-dir-118319-14980-1p4xjo3.wf2mqs38fr\npm-debug.log
npm ERR! code 1

#2

In general it’s a bad idead to try to update packages shipped with JuliaPro. I’m not sure if this is why the update fails for you though – you could try completly uninstalling julia-client and reinstall it.


#3

I know… I am not using the Atom shipped with JuliaPro. Uninstalling it (version 0.6.10) and trying to install 0.6.12 did unfortunately not work.


#4

Atom is failing to install a binary dependency of julia-client. AFACIT, this is either an issue with your internet connection (unlikely since it happened more than once) or (probably) with your anti-virus solution. You might try disabling that and possibly exclude ~/.atom if the installation worked.


#5

I have the same issue and a solution would be much appreciated.


#6

This might help here. I’m still not entirely sure why this is happening…