Atom 1.39 won't build julia-client

Atom auto-updated from 1.38 to 1.39 this morning. When I started it, it sent me a message saying a needed to rebuild some out-of-date packages. I followed the prompt to rebuild, but it failed (sorry, I didn’t save the exact error message). I uninstalled all the Julia associated packages and tried to re-install them using uber-juno. I get the following error message:

"Juno: Error installing package julia-client

Please check your internet connection, or report this to
and we’ll try to help.
Error: Installing “julia-client@0.8.10” failed."

I’m running Julia 1.1.1 on a Windows 10 machine. My internet connection is fine. Is anyone else experiencing this issue?


Shoot, same here.

prebuild-install WARN install No prebuilt binaries found (target=3.1.10 runtime=electron arch=x64 libc= platform=win32)
gyp ERR! configure error 
gyp ERR! stack Error: Can't find Python executable "python", you can set the PYTHON env variable.
gyp ERR! stack     at PythonFinder.failNoPython (C:\Users\PetrKrysl\AppData\Local\atom\app-1.39.0\resources\app\apm\node_modules\npm\node_modules\node-gyp\lib\configure.js:492:19)
gyp ERR! stack     at PythonFinder.<anonymous> (C:\Users\PetrKrysl\AppData\Local\atom\app-1.39.0\resources\app\apm\node_modules\npm\node_modules\node-gyp\lib\configure.js:517:16)
gyp ERR! stack     at C:\Users\PetrKrysl\AppData\Local\atom\app-1.39.0\resources\app\apm\node_modules\npm\node_modules\graceful-fs\polyfills.js:284:29
gyp ERR! stack     at FSReqWrap.oncomplete (fs.js:152:21)
gyp ERR! System Windows_NT 10.0.17134
gyp ERR! command "C:\\Users\\PetrKrysl\\AppData\\Local\\atom\\app-1.39.0\\resources\\app\\apm\\bin\\node.exe" "C:\\Users\\PetrKrysl\\AppData\\Local\\atom\\app-1.39.0\\resources\\app\\apm\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild" "--build_v8_with_gn=false"
gyp ERR! cwd C:\Users\PetrKrysl\.atom\packages\julia-client\node_modules\node-pty-prebuilt
gyp ERR! node -v v8.9.3
gyp ERR! node-gyp -v v3.7.0
gyp ERR! not ok 
npm ERR! errno 1
npm ERR! node-pty-prebuilt@0.7.6 install: `prebuild-install || node scripts/install.js`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the node-pty-prebuilt@0.7.6 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\PetrKrysl\.atom\.apm\_logs\2019-07-23T18_23_35_204Z-debug.log

Yeah, I’m on it. Will try to release a patch as soon as possible, but am a bit tied up with JuliaCon…


No worries :blush:

The error I get is that atom detected python 3, but Juno uses gyp, which only supports python2. One way around this until it gets patched is to:

In terminal:

  • set the PATH variable so that python points to your python2
  • run apm install julia-client
  • then run atom
  • (inside atom gui, you may need the env-from-shell plugin to make atom see the PATH variable, activate by cmd-p [Command Palette> env-from-shell:copy])

The rebuild will then run.


I basically can never upgrade julia to use with Atom!

I had julia v0.6 and it was working fine with Atom 1.39.
I installed v0.7, then all the Julia menu options disappeared. I simply changed the julia destination in julia-client package settings, nothing happened. I unistalled julia-client, tried to install again, I get the python error.
I only seem to have Python36-32 and the error:

gyp ERR! stack Error: Can't find Python executable "C:\Users\Aristeidis\AppData\Local\Programs\Python\Python36-32\python.EXE", you can set the PYTHON env variable.

is asking for a file that exists!
If gyp cannot see python3 (if 36-32 is python3), then why was it working before with julia v0.6?

Last time I upgraded julia from v0.4 to v0.6, nothing worked again, I had to uninstall everything.

Thank you for the help in advance.

Making sure a python2 was found first on the path in the environment in which I started Atom was enough to get things to rebuild successfully. Thanks for the tip.

I also encounter this bug today which seems so weird. With the old version of Atom, everything work fine. Hope it could be fixed soon.

1 Like

Identical issue to OP. Installed updates and lost Julia.


Same issue here :slight_smile:

1 Like

Same issue here. I remove my configuration folder and try to install the package.

I get other error message:

/snap/core/current/lib/x86_64-linux-gnu/ version 'GLIBC_2.28' not found (required by ~/.atom/packages/julia-client/node_modules/node-pty-prebuilt/build/Release/pty.node)

1 Like

Hi, it’s a problem with the versions of some dependencies, see this issue. Happened to me as well. Simple and quick solution, without any cost for reverting it once it’s fixed:

You can just download the ZIP version (e.g. of Atom from release 1.38.2, unzip it somehwere and run atom.exe. It will use your config (packages, settings, etc.) as a “native” installation, but not auto-update itself :wink:

And, once the problem is fixed, you can switch back to your actually installed Atom without re-installing anything.


Hi, I tried your fix but it didnt work for me. The julia tool bar doesnt show up on the left anymore, and when i select the packages drop down menu, julia or juno dont show even though it says everything installed successfully

1 Like

Same issue here,

1 Like

I had to go though my hard drive and remove several folders belonging to Atom, they don’t remove on an uninstall.

The fix by asprionj seems better because its a standalone version (if I understand correctly).

So I had done that on my work desktop, didnt work. but with foresight, when I got home, i didnt start up Atom, not giving it the chance to update itself, but applied asprionj’s fix and it worked. so im sticking with that (and running my code from home) until ‘they’ fix Atom 1.39

I followed your instructions, but julia client isn’t installed/built on this “version” and therefore I cannot run my code. Did I miss something ?

1 Like

No, you didn’t miss anything. This worked straight ahead for me. Sorry, can’t help you much since I cannot reproduce your situation. What happens if you remove and re-install julia client (or entire uber-juno)…?

[Obsolete now; the issue is solved, see below.]

The only workaround that works for me so far (on macOS 10.14.6) is to

  1. completely uninstall Atom 1.39.1, including ~/.atom;
  2. install Atom 1.38.2 from here:;
  3. go to Preferences and reinstall uber-juno until the error message for julia-client occurs;
  4. then, in the Terminal, run: apm install julia-client@0.8.9;
  5. and deactive the auto-update until the issue will be fixed. :o)

Trying to install julia-client 0.8.12-alpha immediately crashes Atom 1.39.1.

1 Like

Alright, I got a couple reports that julia-client@0.8.12-beta2 works fine on MacOS (as well as on Windows and Linux).

Sorry for the trouble!